Skip to content

Commit

Permalink
pypi-keyring: Autospec creation for update from version 23.5.0 to ver…
Browse files Browse the repository at this point in the history
…sion 23.5.1

Anderson Bravalheri (1):
      Ignore flake8/black warnings with pytest 7.0.1 (jaraco/skeleton#58)

Dave Gaeddert (1):
      Add .coverage.* to gitignore

Dos Moonen (4):
      Add failing test for keyring.util.platform_.config_root
      Fix keyring.util.platform_.config_root on Windows
      Added entry in CHANGES.rst
      Use Pytest's skipif decorator instead of returning to skip assert statements.

Jason R. Coombs (9):
      Update badge year
      Remove setup.py, no longer needed.
      Add exclusions for pytest 7 deprecations in plugins. Fixes jaraco/skeleton#57.
      Use the parent category PytestDeprecationWarning, which is available on older pytest versions. Fixes jaraco/skeleton#57.
      Bump pytest-mypy and remove workaround for realpython/pytest-mypy#131.
      Require jaraco.packaging 9 adding compatibility for projects with no setup.py file.
      Ran pre-commit autoupdate
      Use actual version number.
      Trim test down.

Sviatoslav Sydorenko (1):
      Inject check job into CI workflow as ultimate flag (#55)
  • Loading branch information
fenrus75 committed May 23, 2022
1 parent 667ff32 commit a61d156
Show file tree
Hide file tree
Showing 6 changed files with 35 additions and 14 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-keyring
URL = https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
URL = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-keyring
url = https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
url = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
archives =
giturl = https://github.com/jaraco/keyring/
domain =
Expand Down
39 changes: 30 additions & 9 deletions pypi-keyring.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,13 +3,13 @@
# Generated by: autospec.py
#
Name : pypi-keyring
Version : 23.5.0
Release : 115
URL : https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/22/2b/e840597838cc63f96926bd7daca67936031635cfe6c81ee12dc652bd2dce/keyring-23.5.0.tar.gz
Version : 23.5.1
Release : 116
URL : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
Summary : Store and access your passwords safely.
Group : Development/Tools
License : MIT
License : MIT Python-2.0
Requires: pypi-keyring-bin = %{version}-%{release}
Requires: pypi-keyring-license = %{version}-%{release}
Requires: pypi-keyring-python = %{version}-%{release}
Expand Down Expand Up @@ -68,15 +68,18 @@ python3 components for the pypi-keyring package.


%prep
%setup -q -n keyring-23.5.0
cd %{_builddir}/keyring-23.5.0
%setup -q -n keyring-23.5.1
cd %{_builddir}/keyring-23.5.1
pushd ..
cp -a keyring-23.5.1 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1649777144
export SOURCE_DATE_EPOCH=1653336156
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -87,6 +90,15 @@ export FFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
pushd ../buildavx2/
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
python3 -m build --wheel --skip-dependency-check --no-isolation

popd

%check
export http_proxy=http://127.0.0.1:9/
Expand All @@ -97,11 +109,20 @@ python setup.py ptr || :
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-keyring
cp %{_builddir}/keyring-23.5.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/keyring-23.5.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
pushd ../buildavx2/
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
pip install --root=%{buildroot}-v3 --no-deps --ignore-installed dist/*.whl
popd
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot}/usr/share/clear/optimized-elf/ %{buildroot}/usr/share/clear/filemap/filemap-%{name}

%files
%defattr(-,root,root,-)
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
115
116
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
bec0f73355b3a95df95769b80980cb8b5ca8dd57/keyring-23.5.0.tar.gz
89f9754ddc5bf93f3b1b1fe83606aca06d130ae1/keyring-23.5.1.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
23.5.0
23.5.1

0 comments on commit a61d156

Please sign in to comment.