Skip to content

Commit

Permalink
pypi-keyring: Autospec creation for update from version 23.5.1 to ver…
Browse files Browse the repository at this point in the history
…sion 23.6.0

Anderson Bravalheri (1):
      Update Github actions to v3 (#62)

Hugo van Kemenade (1):
      Update base URL for PEPs (#61)

Jason R. Coombs (7):
      Move conditional import to a module to reduce duplicity. Re-worded the import to make it more symmetrical.
      Update changelog.
      Add test capturing need for an alternate keyring with an alternate keychain.
      Add support for getting another Keyring with an alternate keychain. Fixes #579.
      Update changelog.
      Add Python 3.11 into the matrix using workaround from actions/setup-python#213. Drop 3.9 from matrix for efficiency.
      Add Python 3.11 into the matrix using workaround from actions/setup-python#213. Drop 3.9 from matrix for efficiency.

Prabhav Khera (2):
      Update setup.cfg
      Update tests/test_packaging.py

probro27 (6):
      Changed importlib_metadata to have requirement for < python 3.10
      Updated imports
      Updated imports
      Added ignore tag to imports
      Trying to fix imports
      Imports fixed with formatting

wim glenn (1):
      exclude build env from cov reporting (#60)
  • Loading branch information
fenrus75 committed Jun 8, 2022
1 parent 8ec51b8 commit deb3f75
Show file tree
Hide file tree
Showing 6 changed files with 16 additions and 18 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-keyring
URL = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
URL = https://files.pythonhosted.org/packages/a4/9e/9d9eb6a6dc4f347bae8200a2e1dd65a7b96ae99e29ef8f7452ccc4ef9eea/keyring-23.6.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-keyring
url = https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
url = https://files.pythonhosted.org/packages/a4/9e/9d9eb6a6dc4f347bae8200a2e1dd65a7b96ae99e29ef8f7452ccc4ef9eea/keyring-23.6.0.tar.gz
archives =
giturl = https://github.com/jaraco/keyring/
domain =
Expand Down
24 changes: 11 additions & 13 deletions pypi-keyring.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : pypi-keyring
Version : 23.5.1
Release : 117
URL : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/0b/c6/87aaea22b32a85c1eb786ee77844f826103e65e9c0a0c4df1f95ec23d3be/keyring-23.5.1.tar.gz
Version : 23.6.0
Release : 118
URL : https://files.pythonhosted.org/packages/a4/9e/9d9eb6a6dc4f347bae8200a2e1dd65a7b96ae99e29ef8f7452ccc4ef9eea/keyring-23.6.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/a4/9e/9d9eb6a6dc4f347bae8200a2e1dd65a7b96ae99e29ef8f7452ccc4ef9eea/keyring-23.6.0.tar.gz
Summary : Store and access your passwords safely.
Group : Development/Tools
License : MIT Python-2.0
Expand All @@ -16,7 +16,6 @@ Requires: pypi-keyring-python = %{version}-%{release}
Requires: pypi-keyring-python3 = %{version}-%{release}
Requires: pypi(secretstorage)
BuildRequires : buildreq-distutils3
BuildRequires : pypi(importlib_metadata)
BuildRequires : pypi(jeepney)
BuildRequires : pypi(secretstorage)
BuildRequires : pypi(setuptools)
Expand Down Expand Up @@ -59,7 +58,6 @@ Summary: python3 components for the pypi-keyring package.
Group: Default
Requires: python3-core
Provides: pypi(keyring)
Requires: pypi(importlib_metadata)
Requires: pypi(jeepney)
Requires: pypi(secretstorage)

Expand All @@ -68,18 +66,18 @@ python3 components for the pypi-keyring package.


%prep
%setup -q -n keyring-23.5.1
cd %{_builddir}/keyring-23.5.1
%setup -q -n keyring-23.6.0
cd %{_builddir}/keyring-23.6.0
pushd ..
cp -a keyring-23.5.1 buildavx2
cp -a keyring-23.6.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1653341002
export SOURCE_DATE_EPOCH=1654700408
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -91,8 +89,8 @@ export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
pushd ../buildavx2/
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx"
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 -msse2avx "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
Expand All @@ -109,7 +107,7 @@ python setup.py ptr || :
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-keyring
cp %{_builddir}/keyring-23.5.1/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/keyring-23.6.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-keyring/8e6689d37f82d5617b7f7f7232c94024d41066d1
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
117
118
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
89f9754ddc5bf93f3b1b1fe83606aca06d130ae1/keyring-23.5.1.tar.gz
390804736dc6242d7a2e992e9c628cada48b4ee7/keyring-23.6.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
23.5.1
23.6.0

0 comments on commit deb3f75

Please sign in to comment.