Skip to content

Commit

Permalink
pypi-setuptools: Autospec creation for update from version 60.2.0 to …
Browse files Browse the repository at this point in the history
…version 60.5.0

Ananth Pattabiraman (3):
      add resources on packaging
      add 2674 changelog
      Update docs/userguide/quickstart.rst

Anderson Bravalheri (34):
      Configure pytest to enable/disable integration tests
      Add integration test based on feedback from #2849
      Add tox environment for integration tests
      Run integration tests before release on CI
      Add news fragment about integration tests
      Disable pytest plugins in integration tests via -p no:*
      Use separated "extras" for integration tests
      Fix flake8 errors for conftest.py
      Simulate pip's isolation using virtualenv
      Use shutil to find executable
      Separate some reusable integration helpers
      Use '=' as setup.cfg delimiter for extras option
      Change vendoring script to preserve license files
      Add news fragment
      Remove license lookup in *.egg-info
      Improve path handling on move_license task
      Rename `docs/{images/README => artwork}.rst`
      Replace in-tree sphinx extension with sphinx-favicon
      Use an SVG optimiser
      Add news fragment
      Remove unused imports from docs/conf.py
      Add SETUPTOOLS_USE_DISTUTILS configuration to integration tests
      Allow integration tests to be manually triggered in GitHub Actions
      Add fixtures for sdist and wheel artifacts
      Extract venv fixtures from test_distutils_adoption
      Replace tmp_src fixture with the virtualenv fixtures
      Remove dependency on pytest_virtualenv
      Prevent some tests from inadvertently using the project root for builds
      Add news fragment
      Use setuptools wheel instead of source tree in integration tests
      Ensure test_cygwin pass before CI release action
      Fix misplaced news fragment
      Remove `numpy` sdists from integration tests
      Add test to make sure 3.10 is not interpreted as 3.1

Anthony Sottile (1):
      set origin= for distutils.__spec__

Christian Heimes (7):
      Speedup startup of Python by importing less
      Add changelog entry
      Temporarily add back filter, tests fail without it
      Use internal warnings API and _TrivialRe hack to install filter
      Move filter into meta finder
      Suppress distutils deprecation warning
      pytest.ini uses tabs

Christoph Reiter (1):
      tests: fix usage of requires_zlib() decorator

FX Coudert (1):
      bpo-42504: fix for MACOSX_DEPLOYMENT_TARGET=11 (GH-23556)

Jason R. Coombs (19):
      In tests, add compatibility shim py38compat.requires_zlib.
      Include Python 3.8 in tests. Ref pypa/distutils#100.
      Add another exception for the exclusion for pip. Fixes #2993.
      Add DictStack from jaraco.collections.
      In install command, honor config_vars from sysconfig. Fixes pypa/distutils#103.
      Use 'dict()' instead of '.copy()', for compatibility with DictStack.
      Update changelog.
      Bump version: 60.2.0 → 60.3.0
      Update DictStack implementation from jaraco.collections 3.5.1
      Update changelog.
      Add test capturing failure. Ref #3002.
      Suppress AttributeError when detecting get-pip. Fixes #3002.
      Remove the env, as the test suite runs local by default but also tests stdlib.
      Extract the SYSTEMROOT handler and document it.
      Bump version: 60.3.0 → 60.3.1
      Capture performance of interpreter startup. Ref #3006.
      Check that distutils has an origin. Ref #2990.
      Bump version: 60.3.1 → 60.4.0
      Bump version: 60.4.0 → 60.5.0

Matthew Suozzo (6):
      Maintain `requires` order in METADATA.
      Revert inner function name change.
      Add news entry.
      Remove pkg_resources nondeterminism.
      Add new test to document expected order stability.
      Use MappingProxyType to ensure immutability.

Ronald Oussoren (2):
      bpo-41100: Support macOS 11 and Apple Silicon (GH-22855)
      bpo-42504: Ensure that get_config_var('MACOSX_DEPLOYMENT_TARGET') is a string (GH-24341)

liuzhe (1):
      fix version parsing
  • Loading branch information
fenrus75 committed Jan 11, 2022
1 parent 50c1108 commit a7f9bb9
Show file tree
Hide file tree
Showing 7 changed files with 18 additions and 16 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-setuptools
URL = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
URL = https://files.pythonhosted.org/packages/69/77/aee1ecacea4d0db740046ce1785e81d16c4b1755af50eceac4ca1a1f8bfd/setuptools-60.5.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-setuptools
url = https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
url = https://files.pythonhosted.org/packages/69/77/aee1ecacea4d0db740046ce1785e81d16c4b1755af50eceac4ca1a1f8bfd/setuptools-60.5.0.tar.gz
archives =
giturl = https://github.com/pypa/setuptools.git
domain =
Expand Down
22 changes: 11 additions & 11 deletions pypi-setuptools.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : pypi-setuptools
Version : 60.2.0
Release : 246
URL : https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/9b/be/13f54335c7dba713b0e97e11e7a41db3df4a85073d6c5a6e7f6468b22ee2/setuptools-60.2.0.tar.gz
Version : 60.5.0
Release : 247
URL : https://files.pythonhosted.org/packages/69/77/aee1ecacea4d0db740046ce1785e81d16c4b1755af50eceac4ca1a1f8bfd/setuptools-60.5.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/69/77/aee1ecacea4d0db740046ce1785e81d16c4b1755af50eceac4ca1a1f8bfd/setuptools-60.5.0.tar.gz
Summary : Easily download, build, install, upgrade, and uninstall Python packages
Group : Development/Tools
License : MIT
Expand All @@ -15,9 +15,6 @@ Requires: pypi-setuptools-license = %{version}-%{release}
Requires: pypi-setuptools-python = %{version}-%{release}
Requires: pypi-setuptools-python3 = %{version}-%{release}
BuildRequires : buildreq-distutils3
Provides: setuptools
Provides: setuptools-python
Provides: setuptools-python3
BuildRequires : setuptools
Patch1: avx2.patch

Expand Down Expand Up @@ -62,16 +59,16 @@ python3 components for the pypi-setuptools package.


%prep
%setup -q -n setuptools-60.2.0
cd %{_builddir}/setuptools-60.2.0
%setup -q -n setuptools-60.5.0
cd %{_builddir}/setuptools-60.5.0
%patch1 -p1

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1641497543
export SOURCE_DATE_EPOCH=1641942931
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -87,7 +84,9 @@ python3 setup.py build
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-setuptools
cp %{_builddir}/setuptools-60.2.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/setuptools-60.5.0/LICENSE %{buildroot}/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
cp %{_builddir}/setuptools-60.5.0/pkg_resources/_vendor/pyparsing.LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-setuptools/df156c6a0a89ed2a3bd4a473c68cf85907509ca0
cp %{_builddir}/setuptools-60.5.0/setuptools/_vendor/pyparsing.LICENSE.txt %{buildroot}/usr/share/package-licenses/pypi-setuptools/df156c6a0a89ed2a3bd4a473c68cf85907509ca0
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
Expand All @@ -108,6 +107,7 @@ chmod 755 %{buildroot}/usr/bin/easy_install_is_deprecated
%files license
%defattr(0644,root,root,0755)
/usr/share/package-licenses/pypi-setuptools/8e6689d37f82d5617b7f7f7232c94024d41066d1
/usr/share/package-licenses/pypi-setuptools/df156c6a0a89ed2a3bd4a473c68cf85907509ca0

%files python
%defattr(-,root,root,-)
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
246
247
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3f9f2c673ce97c6f479acf65cf7cbb1ab9055895/setuptools-60.2.0.tar.gz
c251a4c2a44e961dc5e83be5b7894739ab70a30d/setuptools-60.5.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
60.2.0
60.5.0
2 changes: 2 additions & 0 deletions whatrequires
Original file line number Diff line number Diff line change
@@ -1 +1,3 @@
# This file contains recursive sources that require this package
mozjs78
mozjs91

0 comments on commit a7f9bb9

Please sign in to comment.