Skip to content
This repository has been archived by the owner on Oct 27, 2022. It is now read-only.

Commit

Permalink
zipp: Autospec creation for update from version 3.6.0 to version 3.7.0
Browse files Browse the repository at this point in the history
Jason R. Coombs (8):
      Test on Python 3.10 (final).
      Rely on pytest 6 and drop workaround for pytest-dev/pytest#6178.
      Remove wheel from build requirements. It's implied for wheel builds. Ref pypa/setuptools#1498.
      Fall back to legacy resolver in pip. Workaround for pypa/pip#9143.
      Restore new resolver for pip. Proper fix for pypa/pip#9143.
      Require Python 3.7 or later.
      Remove filtered warnings, addressed upstream.
      Update changelog.
  • Loading branch information
fenrus75 committed Dec 31, 2021
1 parent 7d62ce4 commit 5a6aeb2
Show file tree
Hide file tree
Showing 7 changed files with 17 additions and 16 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := zipp
URL = https://files.pythonhosted.org/packages/02/bf/0d03dbdedb83afec081fefe86cae3a2447250ef1a81ac601a9a56e785401/zipp-3.6.0.tar.gz
URL = https://files.pythonhosted.org/packages/94/64/3115548d41cb001378099cb4fc6a6889c64ef43ac1b0e68c9e80b55884fa/zipp-3.7.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = zipp
url = https://files.pythonhosted.org/packages/02/bf/0d03dbdedb83afec081fefe86cae3a2447250ef1a81ac601a9a56e785401/zipp-3.6.0.tar.gz
url = https://files.pythonhosted.org/packages/94/64/3115548d41cb001378099cb4fc6a6889c64ef43ac1b0e68c9e80b55884fa/zipp-3.7.0.tar.gz
archives =
giturl = https://github.com/jaraco/zipp.git
domain =
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
37
38
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
b5c8b7519876285d93611216b4ecf0a7b5d59174/zipp-3.6.0.tar.gz
f299449e5c02129c41bf8cd229f53a0f804c32c0/zipp-3.7.0.tar.gz
2 changes: 1 addition & 1 deletion versions
Original file line number Diff line number Diff line change
@@ -1 +1 @@
3.6.0
3.7.0
1 change: 0 additions & 1 deletion whatrequires
Original file line number Diff line number Diff line change
@@ -1,5 +1,4 @@
# This file contains recursive sources that require this package
ansible
importlib_metadata
importlib_resources
python-zstandard
22 changes: 12 additions & 10 deletions zipp.spec
Original file line number Diff line number Diff line change
Expand Up @@ -3,10 +3,10 @@
# Generated by: autospec.py
#
Name : zipp
Version : 3.6.0
Release : 37
URL : https://files.pythonhosted.org/packages/02/bf/0d03dbdedb83afec081fefe86cae3a2447250ef1a81ac601a9a56e785401/zipp-3.6.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/02/bf/0d03dbdedb83afec081fefe86cae3a2447250ef1a81ac601a9a56e785401/zipp-3.6.0.tar.gz
Version : 3.7.0
Release : 38
URL : https://files.pythonhosted.org/packages/94/64/3115548d41cb001378099cb4fc6a6889c64ef43ac1b0e68c9e80b55884fa/zipp-3.7.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/94/64/3115548d41cb001378099cb4fc6a6889c64ef43ac1b0e68c9e80b55884fa/zipp-3.7.0.tar.gz
Summary : Backport of pathlib-compatible object wrapper for zip files
Group : Development/Tools
License : MIT
Expand All @@ -16,6 +16,8 @@ Requires: zipp-python3 = %{version}-%{release}
BuildRequires : buildreq-distutils3
BuildRequires : pluggy
BuildRequires : py-python
BuildRequires : pypi(setuptools)
BuildRequires : pypi(setuptools_scm)
BuildRequires : pytest
BuildRequires : setuptools
BuildRequires : setuptools_scm
Expand Down Expand Up @@ -56,15 +58,15 @@ python3 components for the zipp package.


%prep
%setup -q -n zipp-3.6.0
cd %{_builddir}/zipp-3.6.0
%setup -q -n zipp-3.7.0
cd %{_builddir}/zipp-3.7.0

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1632950859
export SOURCE_DATE_EPOCH=1640978901
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -74,14 +76,14 @@ export FCFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
export FFLAGS="$FFLAGS -O3 -ffat-lto-objects -flto=auto "
export CXXFLAGS="$CXXFLAGS -O3 -ffat-lto-objects -flto=auto "
export MAKEFLAGS=%{?_smp_mflags}
python3 setup.py build
python3 -m build --wheel --skip-dependency-check --no-isolation

%install
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/zipp
cp %{_builddir}/zipp-3.6.0/LICENSE %{buildroot}/usr/share/package-licenses/zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1
python3 -tt setup.py build install --root=%{buildroot}
cp %{_builddir}/zipp-3.7.0/LICENSE %{buildroot}/usr/share/package-licenses/zipp/8e6689d37f82d5617b7f7f7232c94024d41066d1
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
Expand Down

0 comments on commit 5a6aeb2

Please sign in to comment.