Skip to content

Commit

Permalink
tools/elfutils: remove no-op copy of tdestroy()
Browse files Browse the repository at this point in the history
A false tdestroy() function was added in order to make elfutils build on
macOS again. A previous commit added declarations for a real version of
tdestroy() into gnulib, which is already imported, as well as the
preprocessor flags and the triggers for the Makefile.am conditional in
order to include the source to be built.

Tested-by: Georgi Valkov <gvalkov@gmail.com> # MacOS
Signed-off-by: Michael Pratt <mcpratt@pm.me>
Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
  • Loading branch information
mcprat authored and guidosarducci committed Apr 16, 2024
1 parent e47a42c commit cb41fde
Showing 1 changed file with 0 additions and 14 deletions.
14 changes: 0 additions & 14 deletions tools/elfutils/patches/100-portability.patch
Original file line number Diff line number Diff line change
Expand Up @@ -344,20 +344,6 @@
+{
+ return ppc_check_object_attribute(ebl, vendor, tag, value, tag_name, value_name);
+}
--- a/lib/libeu.h
+++ b/lib/libeu.h
@@ -45,4 +45,11 @@ extern char *xasprintf(const char *fmt,
extern uint32_t crc32 (uint32_t crc, unsigned char *buf, size_t len);
extern int crc32_file (int fd, uint32_t *resp);

+#ifdef __APPLE__
+static inline void tdestroy(void *root __attribute__ ((unused)),
+ void (*freekey)(void *) __attribute__ ((unused)))
+{
+}
+#endif
+
#endif
--- a/libdwfl/libdwflP.h
+++ b/libdwfl/libdwflP.h
@@ -31,6 +31,8 @@
Expand Down

0 comments on commit cb41fde

Please sign in to comment.