Skip to content

Commit

Permalink
python3: Update to 3.11.5, refresh patches
Browse files Browse the repository at this point in the history
Includes fix for CVE-2023-40217 (Bypass TLS handshake on closed
sockets).

This also:

* Remove 027-install-python3-symlink-after-stdlib.patch

  This was merged upstream in
  python/cpython#104693.

* Remove fix for unnecessary linking with libbsd
  (60bf01c)

  This was fixed upstream in
  python/cpython#105236.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
  • Loading branch information
jefferyto committed Sep 5, 2023
1 parent 1e1b205 commit e7b8a61
Show file tree
Hide file tree
Showing 7 changed files with 16 additions and 25 deletions.
4 changes: 2 additions & 2 deletions lang/python/python3-version.mk
Original file line number Diff line number Diff line change
Expand Up @@ -8,12 +8,12 @@
# Note: keep in sync with setuptools & pip
PYTHON3_VERSION_MAJOR:=3
PYTHON3_VERSION_MINOR:=11
PYTHON3_VERSION_MICRO:=4
PYTHON3_VERSION_MICRO:=5

PYTHON3_VERSION:=$(PYTHON3_VERSION_MAJOR).$(PYTHON3_VERSION_MINOR)

PYTHON3_SETUPTOOLS_PKG_RELEASE:=1
PYTHON3_PIP_PKG_RELEASE:=1

PYTHON3_SETUPTOOLS_VERSION:=65.5.0
PYTHON3_PIP_VERSION:=23.1.2
PYTHON3_PIP_VERSION:=23.2.1
11 changes: 3 additions & 8 deletions lang/python/python3/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,15 +11,15 @@ include $(TOPDIR)/rules.mk
include ../python3-version.mk

PKG_NAME:=python3
PKG_RELEASE:=3
PKG_RELEASE:=1
PKG_VERSION:=$(PYTHON3_VERSION).$(PYTHON3_VERSION_MICRO)

PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://www.python.org/ftp/python/$(PKG_VERSION)
PKG_HASH:=2f0e409df2ab57aa9fc4cbddfb976af44e4e55bf6f619eee6bc5c2297264a7f6
PKG_HASH:=85cd12e9cf1d6d5a45f17f7afe1cebe7ee628d3282281c492e86adf636defa3f

PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=PSF-2.0
PKG_LICENSE:=Python-2.0.1
PKG_LICENSE_FILES:=LICENSE Doc/copyright.rst Doc/license.rst Modules/_ctypes/darwin/LICENSE Modules/_ctypes/libffi_osx/LICENSE Modules/expat/COPYING
PKG_CPE_ID:=cpe:/a:python:python

Expand Down Expand Up @@ -162,11 +162,6 @@ CONFIGURE_VARS += \
ac_cv_file__dev_ptc=no \
ac_cv_file__dev_ptmx=yes

# Do not link with libbsd for flock
# https://github.com/openwrt/packages/issues/21161
CONFIGURE_VARS += \
ac_cv_lib_bsd_flock=no

# Disable stdlib modules
# Check for a better way in the future: https://github.com/python/cpython/issues/98558
CONFIGURE_VARS += \
Expand Down
4 changes: 2 additions & 2 deletions lang/python/python3/patches/003-do-not-run-compileall.patch
Original file line number Diff line number Diff line change
@@ -1,14 +1,14 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -2118,6 +2118,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
@@ -2123,6 +2123,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(INSTALL_DATA) $(srcdir)/Modules/xxmodule.c \
$(DESTDIR)$(LIBDEST)/distutils/tests ; \
fi
+ifeq (1,)
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST) -f \
@@ -2145,6 +2146,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
@@ -2150,6 +2151,7 @@ libinstall: all $(srcdir)/Modules/xxmodu
$(PYTHON_FOR_BUILD) -Wi -OO $(DESTDIR)$(LIBDEST)/compileall.py \
-j0 -d $(LIBDEST)/site-packages -f \
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/Makefile.pre.in
+++ b/Makefile.pre.in
@@ -2163,7 +2163,7 @@ python-config: $(srcdir)/Misc/python-con
@@ -2168,7 +2168,7 @@ python-config: $(srcdir)/Misc/python-con
@ # On Darwin, always use the python version of the script, the shell
@ # version doesn't use the compiler customizations that are provided
@ # in python (_osx_support.py).
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -47,7 +47,7 @@
PY_HASH_ENTRY(NULL, NULL, NULL, 0),
};

@@ -873,11 +889,15 @@ py_evp_fromname(PyObject *module, const
@@ -874,11 +890,15 @@ py_evp_fromname(PyObject *module, const
goto exit;
}

Expand Down

This file was deleted.

7 changes: 7 additions & 0 deletions lang/python/python3/test.sh
Original file line number Diff line number Diff line change
@@ -0,0 +1,7 @@
#!/bin/sh

case "$1" in
python3|python3-base|python3-light)
python3 --version | grep -Fx "Python $2"
;;
esac

0 comments on commit e7b8a61

Please sign in to comment.