Skip to content

Commit

Permalink
temp/conky: downgrade to 1.20.1 (MR 5195)
Browse files Browse the repository at this point in the history
Conky got an issue on Wayland since 1.20.2:

brndnmtthws/conky#1898
(cherry picked from commit 8e5597a)
  • Loading branch information
stacyharper authored and ollieparanoid committed Jun 2, 2024
1 parent 144e1f1 commit f9f84a9
Showing 1 changed file with 62 additions and 0 deletions.
62 changes: 62 additions & 0 deletions temp/conky/APKBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,62 @@
# Old conky version forked from Alpine for Sxmo until this is fixed:
# https://github.com/brndnmtthws/conky/issues/1898
pkgname=conky
pkgver=1.20.1
pkgrel=0
pkgdesc="Advanced, highly configurable system monitor for X based on torsmo"
url="https://github.com/brndnmtthws/conky"
arch="all"
license="GPL-3.0-or-later"
makedepends="
alsa-lib-dev
cairo-dev
cmake
curl-dev
gawk
glib-dev
imlib2-dev
libxdamage-dev
libxext-dev
libxft-dev
libxinerama-dev
libxml2-dev
linux-headers
lua5.4-dev
ncurses-dev
pango-dev
samurai
tolua++
wayland-dev
libxi-dev
wayland-protocols
wireless-tools-dev
"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/brndnmtthws/conky/archive/v$pkgver.tar.gz"
options="!check"

build() {
cmake -B build -G Ninja \
-DRELEASE=ON \
-DCMAKE_BUILD_TYPE=MinSizeRel \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_CURL=ON \
-DBUILD_XDBE=ON \
-DBUILD_IMLIB2=ON \
-DBUILD_RSS=ON \
-DBUILD_WLAN=ON \
-DBUILD_I18N=OFF \
-DBUILD_LUA_CAIRO=ON \
-DBUILD_WAYLAND=ON \
-DLUA_LIBRARIES="/usr/lib/lua5.4/liblua.so"
cmake --build build
}

package() {
DESTDIR="$pkgdir" cmake --install build
install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
}

sha512sums="
60b4da92a42b3ff1a2490c50c7a02eab27a5ce3e91d4e9e0a83d6f0f1089f22c20adec817011afea84bcd99ff19e8f776d852ff4c9249ef47412b58eaa9233da conky-1.20.1.tar.gz
"

0 comments on commit f9f84a9

Please sign in to comment.