Skip to content

Commit

Permalink
py-pebble: update to 5.0.3.
Browse files Browse the repository at this point in the history
5.0.3

Fixes:
 - issue #111: reinstate `Pool.schedule` function in place of
   `Pool.submit`.

5.0.2

Fixes:
 - issue #108: fix build tag enforcing Python 3.6 as minimum
   compatible version.

5.0.1

Improvements:
 - issue #105: run callbacks after process termination on timeout or
   task cancellation

5.0.0

Backward incompatible changes:
 - issue #93: Python 2 is no longer compatible. Minimum supported
   version is now 3.7.

Deprecations:
 - issue #90: pools `schedule` method is now deprecated, use `submit`
   instead.

Features:
 - issue #90: pools are now compatible with asyncio APIs.
 - issue #94: asynchronous function decorators
 - issue #102: type hints have been added to all functionalities
 - issue #103: support alternative multiprocessing.context
   implementations

Fixes:
 - issue #99: fix deadlock when closing a full pipe on Windows in pool
  • Loading branch information
0-wiz-0 committed Apr 30, 2023
1 parent 56bffc2 commit 2c8e23e
Show file tree
Hide file tree
Showing 3 changed files with 19 additions and 15 deletions.
14 changes: 5 additions & 9 deletions devel/py-pebble/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.9 2023/03/29 09:34:08 wiz Exp $
# $NetBSD: Makefile,v 1.10 2023/04/30 17:37:50 wiz Exp $

DISTNAME= Pebble-4.5.3
DISTNAME= Pebble-5.0.3
PKGNAME= ${PYPKGPREFIX}-${DISTNAME:tl}
PKGREVISION= 1
CATEGORIES= devel python
MASTER_SITES= ${MASTER_SITE_PYPI:=P/Pebble/}

Expand All @@ -11,16 +10,13 @@ HOMEPAGE= https://github.com/noxdafox/pebble
COMMENT= Threading and multiprocessing eye-candy
LICENSE= gnu-lgpl-v3

.include "../../lang/python/pyversion.mk"

.if ${PYTHON_VERSION} == 207
DEPENDS+= ${PYPKGPREFIX}-futures-[0-9]*:../../devel/py-futures
.endif
PYTHON_VERSIONS_INCOMPATIBLE= 27

USE_LANGUAGES= # none

TEST_ENV+= PYTHONPATH=${WRKSRC}/build/lib
do-test:
cd ${WRKSRC}/test && ${PYTHONBIN} -m unittest discover -v
cd ${WRKSRC}/test && ${SETENV} ${TEST_ENV} ${PYTHONBIN} -m unittest discover -v

.include "../../lang/python/egg.mk"
.include "../../mk/bsd.pkg.mk"
12 changes: 10 additions & 2 deletions devel/py-pebble/PLIST
Original file line number Diff line number Diff line change
@@ -1,12 +1,20 @@
@comment $NetBSD: PLIST,v 1.1 2019/08/21 12:39:39 adam Exp $
@comment $NetBSD: PLIST,v 1.2 2023/04/30 17:37:50 wiz Exp $
${PYSITELIB}/${EGG_INFODIR}/PKG-INFO
${PYSITELIB}/${EGG_INFODIR}/SOURCES.txt
${PYSITELIB}/${EGG_INFODIR}/dependency_links.txt
${PYSITELIB}/${EGG_INFODIR}/requires.txt
${PYSITELIB}/${EGG_INFODIR}/top_level.txt
${PYSITELIB}/pebble/__init__.py
${PYSITELIB}/pebble/__init__.pyc
${PYSITELIB}/pebble/__init__.pyo
${PYSITELIB}/pebble/asynchronous/__init__.py
${PYSITELIB}/pebble/asynchronous/__init__.pyc
${PYSITELIB}/pebble/asynchronous/__init__.pyo
${PYSITELIB}/pebble/asynchronous/process.py
${PYSITELIB}/pebble/asynchronous/process.pyc
${PYSITELIB}/pebble/asynchronous/process.pyo
${PYSITELIB}/pebble/asynchronous/thread.py
${PYSITELIB}/pebble/asynchronous/thread.pyc
${PYSITELIB}/pebble/asynchronous/thread.pyo
${PYSITELIB}/pebble/common.py
${PYSITELIB}/pebble/common.pyc
${PYSITELIB}/pebble/common.pyo
Expand Down
8 changes: 4 additions & 4 deletions devel/py-pebble/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.9 2021/10/26 10:18:44 nia Exp $
$NetBSD: distinfo,v 1.10 2023/04/30 17:37:50 wiz Exp $

BLAKE2s (Pebble-4.5.3.tar.gz) = 16fb8dbc8bf95decf6a069003dbbd2471b8caac856130b3c63d755bb9f416cd4
SHA512 (Pebble-4.5.3.tar.gz) = e3b17fa6b9ca959560d364e84091e7990921eb9a2aef854c391a5d0e46359b57e5ec1a4239ac97f4c0bb485d0475ad8338c3485c9fdeff7e446a989129738096
Size (Pebble-4.5.3.tar.gz) = 23411 bytes
BLAKE2s (Pebble-5.0.3.tar.gz) = 98ab60981a17165688300388d9602606f39c5c46640c2226c627de83ffcf6b2a
SHA512 (Pebble-5.0.3.tar.gz) = 324cba58905b0be76b2cd56e0ee5d3e51a36d46a7754fbccb1f9307af0747c2f02b81d137e2c4bce1c766706b70ce1a909c3b287676db147c202cab7445fc764
Size (Pebble-5.0.3.tar.gz) = 29076 bytes

0 comments on commit 2c8e23e

Please sign in to comment.