Skip to content

Commit

Permalink
net/ruby-net-imap: add version 0.3.7
Browse files Browse the repository at this point in the history
devel/ruby-redmine51 require net-imap gem version 0.3.4 but ruby31 bundles
0.2.3.  So, it add latest version of net-imap gem 0.3.x as ruby-net-imap.

Ruby client api for Internet Message Access Protocol.


Changes from 0.2.3:

0.3.0 (2022-11-17)

What's Changed

* Added dependabot.yml for actions by @hsbt in #59
* Bump actions/checkout from 2 to 3 by @dependabot in #60
* Adding RFC licenses by @nevans in #57
* Warn when using deprecated SASL mechanisms by @nevans in #62

New Contributors

* @dependabot made their first contribution in #60

0.3.1 (2022-11-17)

What's Changed

* Add XOAUTH2 authenticator by @ssunday in #63

New Contributors

* @ssunday made their first contribution in #63

0.3.2 (2022-12-09)

What's Changed

* Support UIDPLUS extension by @hoffi in #65
* Fixes "bundle exec rake" clash with test/unit by @nevans in #67
* Fix some UIDPLUS issues by @nevans in #69
* Fixes date-time format, and adds decode_datetime by @nevans in #66
* Add SASLprep. Code generated & tested with RFC3454 by @nevans in #64
* Add the UNSELECT command by @nevans in #72
*  Fix mailbox attrs by @nevans in #73
* RFCs and references by @nevans in #71
* Nodocs and remove warning by @nevans in #70
* ResponseParser docs by @nevans in #76
* Response Data docs by @nevans in #75

New Contributors

* @hoffi made their first contribution in #65

0.3.3 (2022-12-21)

What's Changed

* Revert "Fixes "bundle exec rake", clash with test/unit" by @znz in #88

New Contributors

* @znz made their first contribution in #88

0.3.4 (2023-01-18)

What's Changed

* Net::IMAP Client docs by @nevans in #74

0.3.5 (2023-06-12)

* Fix #response documentation error, by @nevans in 87ba74e
* Add RFC3454 data, to support offline testing, by @nevans in #137
* Adds Ruby 3.2 to the CI matrix, by @petergoldstein in #99
* Use reusing workflow, by @hsbt in #151
* Decode UTF-7 more strictly, by @nobu in #152
* ️Continue testing 0.3.x branch against ruby 2.6, by @nevans in 115d190
* Fix decode utf-7 test for ruby 2.6, by @nevans in 7a60c8f
* Fix XOAUTH2 authenticator for ruby 2.6, by @nevans in bd4faa0

0.3.6 (2023-06-12)

* Fixes file permissions regression in v0.3.5 release, reported by
  @aaronjensen in #154

0.3.7 (2023-07-26)

What's Changed

* Backport: Fix for Digest MD5 bad challenges by @nobu in #160 PR for
  backport is #161
  • Loading branch information
taca committed Dec 14, 2023
1 parent d1b2728 commit 40f27ce
Show file tree
Hide file tree
Showing 4 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions net/ruby-net-imap/DESCR
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
Ruby client api for Internet Message Access Protocol.
20 changes: 20 additions & 0 deletions net/ruby-net-imap/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
# $NetBSD: Makefile,v 1.6 2023/12/14 15:24:43 taca Exp $

DISTNAME= net-imap-0.3.7
CATEGORIES= net mail

MAINTAINER= pkgsrc-users@NetBSD.org
HOMEPAGE= https://github.com/ruby/net-imap
COMMENT= Ruby client api for Internet Message Access Protocol
LICENSE= 2-clause-bsd OR ruby-license

USE_LANGUAGES= # none

# This package is mainly for redmine51 on Ruby 3.1.
# (Ruby 3.2 and later have required net-imap gem as standard gem.)
RUBY_VERSIONS_ACCEPTED= 31

.include "../../lang/ruby/rubyversion.mk"

.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"
36 changes: 36 additions & 0 deletions net/ruby-net-imap/PLIST
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
@comment $NetBSD: PLIST,v 1.4 2023/12/14 15:24:43 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/.github/dependabot.yml
${GEM_LIBDIR}/.github/workflows/test.yml
${GEM_LIBDIR}/.gitignore
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/LICENSE.txt
${GEM_LIBDIR}/README.md
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/benchmarks/stringprep.yml
${GEM_LIBDIR}/benchmarks/table-regexps.yml
${GEM_LIBDIR}/docs/styles.css
${GEM_LIBDIR}/lib/net/imap.rb
${GEM_LIBDIR}/lib/net/imap/authenticators.rb
${GEM_LIBDIR}/lib/net/imap/authenticators/cram_md5.rb
${GEM_LIBDIR}/lib/net/imap/authenticators/digest_md5.rb
${GEM_LIBDIR}/lib/net/imap/authenticators/login.rb
${GEM_LIBDIR}/lib/net/imap/authenticators/plain.rb
${GEM_LIBDIR}/lib/net/imap/authenticators/xoauth2.rb
${GEM_LIBDIR}/lib/net/imap/command_data.rb
${GEM_LIBDIR}/lib/net/imap/data_encoding.rb
${GEM_LIBDIR}/lib/net/imap/errors.rb
${GEM_LIBDIR}/lib/net/imap/flags.rb
${GEM_LIBDIR}/lib/net/imap/response_data.rb
${GEM_LIBDIR}/lib/net/imap/response_parser.rb
${GEM_LIBDIR}/lib/net/imap/sasl.rb
${GEM_LIBDIR}/lib/net/imap/sasl/saslprep.rb
${GEM_LIBDIR}/lib/net/imap/sasl/saslprep_tables.rb
${GEM_LIBDIR}/lib/net/imap/sasl/stringprep.rb
${GEM_LIBDIR}/lib/net/imap/sasl/stringprep_tables.rb
${GEM_LIBDIR}/net-imap.gemspec
${GEM_LIBDIR}/rakelib/rdoc.rake
${GEM_LIBDIR}/rakelib/rfcs.rake
${GEM_LIBDIR}/rakelib/saslprep.rake
${GEM_LIBDIR}/rakelib/string_prep_tables_generator.rb
${GEM_HOME}/specifications/${GEM_NAME}.gemspec
5 changes: 5 additions & 0 deletions net/ruby-net-imap/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
$NetBSD: distinfo,v 1.3 2023/12/14 15:24:43 taca Exp $

BLAKE2s (net-imap-0.3.7.gem) = 7a2a6ec286c747da28b23a096262106d92edf4649700a1e9a493b8d7a2755f0b
SHA512 (net-imap-0.3.7.gem) = 1ae502e94a3453669d7db63ac59ee3779f3dd2f715bfc8076c6d45f0595e001db2fbae7eab621eb12e2e78d2a570f821dbef657ff8a14d17ec947e56e6cd871e
Size (net-imap-0.3.7.gem) = 77312 bytes

0 comments on commit 40f27ce

Please sign in to comment.