Skip to content

Commit

Permalink
textproc/ruby-diff-lcs: update to 1.5.0
Browse files Browse the repository at this point in the history
1.5.0 (2021-12-23)

* Updated the CI configuration and monkey-patch Hoe.

* Kenichi Kamiya fixed a test configuration deprecation in SimpleCov.  #69

* Tien introduced several corrections and code improvements:

	o Removed an off-by-one error when calculating an index value by
	  embracing Ruby iteration properly.  This had a side-effect of
	  fixing a long-standing bug in #traverse_sequences where the
	  traversal would not be transitive.  That is, LCS(s2, s1) should
	  produce a sequence that is transitive with LCS(s1, s2) on
	  traversal, and applying the diff computed from those results would
	  result in equivalent changes that could be played forward or
	  backward as appropriate. #71, #75

	o The above fix resulted in a changed order of the longest common
	  subsequence when callbacks were applied.  After analysis, it was
	  determined that the computed subsequence was equivalent to the
	  prior version, so the test was updated.  This also resulted in the
	  clarification of documentation when traversing the subsequences.
	  #79

	o An infinite loop case in the case where Diff::LCS would be
	  included into an enumerable class has been fixed.  #73

	o Clarified the purpose of a threshold test in calculation of
	  LCS. #72, #80

* Removed autotest directory
  • Loading branch information
taca committed Apr 29, 2022
1 parent ffd3abc commit 7f65714
Show file tree
Hide file tree
Showing 3 changed files with 24 additions and 10 deletions.
8 changes: 4 additions & 4 deletions textproc/ruby-diff-lcs/Makefile
Original file line number Diff line number Diff line change
@@ -1,12 +1,12 @@
# $NetBSD: Makefile,v 1.23 2020/09/14 14:26:02 taca Exp $
# $NetBSD: Makefile,v 1.24 2022/04/29 06:41:31 taca Exp $

DISTNAME= diff-lcs-1.4.4
DISTNAME= diff-lcs-1.5.0
CATEGORIES= textproc

MAINTAINER= pkgsrc-users@NetBSD.org
#HOMEPAGE= http://diff-lcs.rubyforge.org/
HOMEPAGE= https://github.com/halostatue/diff-lcs
COMMENT= Diff library for Ruby
LICENSE= gnu-gpl-v2 OR artistic OR ruby-license
LICENSE= mit OR gnu-gpl-v2 OR artistic-2.0

RUBYGEM_OPTIONS+= --format-executable

Expand Down
18 changes: 16 additions & 2 deletions textproc/ruby-diff-lcs/PLIST
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
@comment $NetBSD: PLIST,v 1.8 2020/09/14 14:26:02 taca Exp $
@comment $NetBSD: PLIST,v 1.9 2022/04/29 06:41:31 taca Exp $
bin/htmldiff${RUBY_SUFFIX}
bin/ldiff${RUBY_SUFFIX}
${GEM_HOME}/cache/${GEM_NAME}.gem
Expand All @@ -10,7 +10,6 @@ ${GEM_LIBDIR}/License.md
${GEM_LIBDIR}/Manifest.txt
${GEM_LIBDIR}/README.rdoc
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/autotest/discover.rb
${GEM_LIBDIR}/bin/htmldiff
${GEM_LIBDIR}/bin/ldiff
${GEM_LIBDIR}/docs/COPYING.txt
Expand Down Expand Up @@ -38,6 +37,21 @@ ${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff-c
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff-e
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff-f
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff-u
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef-c
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef-e
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef-f
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef-u
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2-c
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2-d
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2-e
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2-f
${GEM_LIBDIR}/spec/fixtures/ldiff/output.diff.chef2-u
${GEM_LIBDIR}/spec/fixtures/new-chef
${GEM_LIBDIR}/spec/fixtures/new-chef2
${GEM_LIBDIR}/spec/fixtures/old-chef
${GEM_LIBDIR}/spec/fixtures/old-chef2
${GEM_LIBDIR}/spec/hunk_spec.rb
${GEM_LIBDIR}/spec/issues_spec.rb
${GEM_LIBDIR}/spec/lcs_spec.rb
Expand Down
8 changes: 4 additions & 4 deletions textproc/ruby-diff-lcs/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.10 2021/10/26 11:23:22 nia Exp $
$NetBSD: distinfo,v 1.11 2022/04/29 06:41:31 taca Exp $

BLAKE2s (diff-lcs-1.4.4.gem) = 180f4a8113ddbabd485ba16aa3a5d0de42a387b8a7abf3ef9a044319f64c0ac4
SHA512 (diff-lcs-1.4.4.gem) = fcc6c86f392697c4b3690827f7c20d50fe68e367626b85a56446356d7bb21b4020bdb2bc5c2faf4e82807cd9f3049d71c94d166c85a1a4231f0fd9fc032f41c7
Size (diff-lcs-1.4.4.gem) = 50688 bytes
BLAKE2s (diff-lcs-1.5.0.gem) = 6d3026d16c5aaab6a5efc25ecb8bd6982c01b8d14ff853f676f020bf7b7f3f43
SHA512 (diff-lcs-1.5.0.gem) = 5cef9dc1d143217cc402173e2b84ffdcbb8d5a4d05716bdbca732ac00d73591e4cab2f7e792382a3686d8e72fdc32269fd7100941d602ca6d683e7645229ef8d
Size (diff-lcs-1.5.0.gem) = 52736 bytes

0 comments on commit 7f65714

Please sign in to comment.