Skip to content

Commit

Permalink
(devel/R-xfun) Updated 0.8 to 0.17
Browse files Browse the repository at this point in the history
# CHANGES IN xfun VERSION 0.17

## NEW FEATURES

- Supports `xfun::pkg_attach(packages, install = "pak")`, i.e., use `pak::pkg_install()` to install a package when it is not installed (thanks, @GitHunter0, #32).

- Added a new function `xfun::split_source()` to split lines of R source code into minimal complete expressions.

# CHANGES IN xfun VERSION 0.16

- Added a new function `base64_decode()` to decode data from the base64 encoding (thanks, @wush978, #31).

# CHANGES IN xfun VERSION 0.15

## NEW FEATURES

- Added a new function `tree()`, which is based on `str()` in base R, but changes the output of `str()` into a tree diagram to make it easier to understand nested data structures.

- Added a new function `base64_encode()` to encode data into the base64 encoding (thanks, @wush978, #27).

- Added a new function `base64_uri()` to generate the Data URI (or Data URL) for a file.

## BUG FIXES

- Fenced code blocks commented out in `<!-- -->` are not longer recognized as code blocks but prose (thanks, @jarauh, #25).

# CHANGES IN xfun VERSION 0.14

## NEW FEATURES

- The `cache_rds()` function can invalidate the cache automatically when the code passed to its `expr` argument has changed. Two new arguments, `hash` and `clean` were added to this function to make it more useful and powerful. See the help page `?xfun::cache_rds()` for more information.

# CHANGES IN xfun VERSION 0.13

## NEW FEATURES

- Added a new function `cache_rds()` to cache an R expression to a `*.rds` file.

- Added a new function `Rscript_call()` to call a function (with arguments) in a new R session via the command `Rscript`.

- The `recheck` argument of `rev_check()` can take a vector of package names, and only these packages will be checked. See `?xfun::rev_check` for more details.

# CHANGES IN xfun VERSION 0.12

## NEW FEATURES

- Added a new function `split_lines()`.

# CHANGES IN xfun VERSION 0.11

## BUG FIXES

- `read_utf8()` will read the file with `options(encoding = 'native.enc')` and ignore user's setting such as `options(encoding = 'UTF-8')` (#21).

# CHANGES IN xfun VERSION 0.10

## NEW FEATURES

- Added the function `as_strict_list()` to convert an existing object to a strict list without wrapping it in another list if the object already is of type list (in contrast to how `strict_list()` behaves) (thanks, @salim-b, #20).

# CHANGES IN xfun VERSION 0.9

## NEW FEATURES

- Added a function `rename_seq()` to rename files to add an incremental numeric prefix to the filenames, e.g., rename `a.txt`, `b.txt`, `c.txt` to `1-a.txt`, `2-b.txt`, `3-c.txt`.
  • Loading branch information
mef committed Sep 20, 2020
1 parent 66a0976 commit 937e762
Show file tree
Hide file tree
Showing 2 changed files with 14 additions and 8 deletions.
12 changes: 9 additions & 3 deletions devel/R-xfun/Makefile
Original file line number Diff line number Diff line change
@@ -1,14 +1,20 @@
# $NetBSD: Makefile,v 1.2 2019/08/08 19:53:41 brook Exp $
# $NetBSD: Makefile,v 1.3 2020/09/20 01:25:06 mef Exp $

R_PKGNAME= xfun
R_PKGVER= 0.8
R_PKGVER= 0.17
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
COMMENT= Miscellaneous functions by 'Yihui Xie'
LICENSE= mit

USE_LANGUAGES= # none
# Packages suggested but not available:
# 'testit', 'pak'
TEST_DEPENDS+= R-knitr-[0-9]*:../../print/R-knitr
TEST_DEPENDS+= R-rmarkdown-[0-9]*:../../textproc/R-rmarkdown
TEST_DEPENDS+= R-tinytex-[0-9]*:../../print/R-tinytex

USE_LANGUAGES= c c++

.include "../../math/R/Makefile.extension"
.include "../../mk/bsd.pkg.mk"
10 changes: 5 additions & 5 deletions devel/R-xfun/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2019/07/31 01:29:17 brook Exp $
$NetBSD: distinfo,v 1.2 2020/09/20 01:25:06 mef Exp $

SHA1 (R/xfun_0.8.tar.gz) = 91b56534ae5c1694b7986fcb65d457a887603ccd
RMD160 (R/xfun_0.8.tar.gz) = 5bae41ce08ff350cb7d6dda8519017bc37983f39
SHA512 (R/xfun_0.8.tar.gz) = efcd5ea5285d87cf557e9cad51f3a2b017f4fd2eb4e6083b74f7d1d4f4bcfb5c1735d3d1912effdd2cebddd05e5951bf1d28d9165e49ac392d6dfde5dc29e8b8
Size (R/xfun_0.8.tar.gz) = 54885 bytes
SHA1 (R/xfun_0.17.tar.gz) = d0db33995538e386ea9cc02f4b4d2bd643fdfac2
RMD160 (R/xfun_0.17.tar.gz) = 81b291f69863b295b84bf195297c9b565e382f91
SHA512 (R/xfun_0.17.tar.gz) = 8b19b7367bd51b04ef7b81d01c84f3ccb4d2035a87f0d56466093ed929f2ef44bb487943e8e8740ae988d7ad64a2a427c958dd66836cb38b1abd0396c77cb3ee
Size (R/xfun_0.17.tar.gz) = 77239 bytes

0 comments on commit 937e762

Please sign in to comment.