Skip to content

Commit

Permalink
alpine: fix subst on macOS
Browse files Browse the repository at this point in the history
The alpine's Makefile has source string substitution for panic( to Panic(.
However, both the file name search pattern and the replacement string search
pattern is no longer complete, causing some alpine_panic() to still exist,
while the definition has changed to alpine_Panic().

From kflu via github.

Closes #113
  • Loading branch information
bsiegert committed Jan 15, 2023
1 parent 64497de commit b299d34
Showing 1 changed file with 4 additions and 2 deletions.
6 changes: 4 additions & 2 deletions mail/alpine/Makefile
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: Makefile,v 1.51 2022/06/28 11:34:16 wiz Exp $
# $NetBSD: Makefile,v 1.52 2023/01/15 17:31:01 bsiegert Exp $

DISTNAME= alpine-2.25
PKGREVISION= 2
Expand Down Expand Up @@ -43,8 +43,10 @@ SUBST_CLASSES.Darwin+= panic
SUBST_STAGE.panic= pre-configure
SUBST_MESSAGE.panic= Renaming the panic function
SUBST_FILES.panic= */*.c
SUBST_FILES.panic+= */*/*.c
SUBST_FILES.panic+= */*/*/*.c
SUBST_FILES.panic+= pith/util.h
SUBST_SED.panic+= -e 's,panic(,Panic(,g'
SUBST_SED.panic+= -e 's,panic *(,Panic(,g'

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/alpine/alpine ${DESTDIR}${PREFIX}/bin/alpine
Expand Down

0 comments on commit b299d34

Please sign in to comment.