Skip to content

Commit

Permalink
(devel/R-waldo) Updated 0.2.5 to 0.3.0, make test passes
Browse files Browse the repository at this point in the history
# waldo 0.3.0

* `compare()` is now considerably faster when comparing complex objects that
  don't have any differences (thanks to strategic use of `identical()`) (#86).

* `compare()` gains two improvements to low-level diffs:

    * Structurally identical data frames (#78) and numeric matrices (#76) gain
      a row-by-row diff that makes it easier to see where exactly values differ.

    * An element-by-element diff will be automatically used if it's shorter than
      the "smart" diff. This improves diff quality when comparing two vectors
      that aren't really related (#68).

* `compare()` gains a `list_as_map` argument thanks to an idea from @dmurdoch.
  It allows you to compare the behaviour of two lists when they are used to
  connect names to values (i.e. the list is operating as a map or dictionary).
  It removes `NULL`s and sorts named components (#72).

* The objects involved in `compare()` (as opposed to the caller of `compare()`)
  gained much greater ability to control the comparison.

    * Objects can now contain a `waldo_opts` attribute, a list with the same
      names and valid values as the arguments to `compare()`, which overrides
      the default comparisons (@dmurdoch).

    * `compare_proxy()` is now called earlier (before type comparison) making
      it more flexible (#65).

    * `compare_proxy()` gains a second argument, `path`, used to report how the
      proxy changed the object. This makes it easier to see when and how a proxy
      is used (#73).

    * Proxies now exist for comparing RProtoBuf objects, converting them to
      proto text format (#82, @michaelquinn32).

* Comparing a list with symbol to a list without that element no longer errors
  (@mgirlich, #79).
  • Loading branch information
mef committed Sep 8, 2021
1 parent 13fc1b9 commit bc8ca12
Show file tree
Hide file tree
Showing 2 changed files with 10 additions and 7 deletions.
7 changes: 5 additions & 2 deletions devel/R-waldo/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.3 2021/06/06 13:57:00 mef Exp $
# $NetBSD: Makefile,v 1.4 2021/09/08 10:44:19 mef Exp $

R_PKGNAME= waldo
R_PKGVER= 0.2.5
R_PKGVER= 0.3.0
CATEGORIES= devel

MAINTAINER= pkgsrc-users@NetBSD.org
Expand All @@ -17,6 +17,9 @@ DEPENDS+= R-rlang>=0.4.7:../../devel/R-rlang
DEPENDS+= R-tibble>=2.1.3:../../math/R-tibble

TEST_DEPENDS+= R-rematch2-[0-9]*:../../devel/R-rematch2
TEST_DEPENDS+= R-covr-[0-9]*:../../devel/R-covr
TEST_DEPENDS+= R-xml2-[0-9]*:../../textproc/R-xml2
TEST_DEPENDS+= R-testthat-[0-9]*:../../devel/R-testthat

USE_LANGUAGES= # none

Expand Down
10 changes: 5 additions & 5 deletions devel/R-waldo/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.2 2021/06/06 13:57:00 mef Exp $
$NetBSD: distinfo,v 1.3 2021/09/08 10:44:19 mef Exp $

SHA1 (R/waldo_0.2.5.tar.gz) = 9f9cf9330fc044100bdee305cf37f011923629e8
RMD160 (R/waldo_0.2.5.tar.gz) = 3cec5a6dee3f7971b385835a7d11c618fa7e4efa
SHA512 (R/waldo_0.2.5.tar.gz) = b94540663ece80b62fb423b4016ad7e5a82dd6a6905a1f7a237d0c795fc0823dbb3eeb03db32885ead1d9d6d5e03ac1b90427e7f38556730207d3bf745159131
Size (R/waldo_0.2.5.tar.gz) = 26295 bytes
SHA1 (R/waldo_0.3.0.tar.gz) = 32a62c08314e56812ef687e212f81579d09d35eb
RMD160 (R/waldo_0.3.0.tar.gz) = ff32f0b67464f1b0d55b688c57922937df958dd3
SHA512 (R/waldo_0.3.0.tar.gz) = 3c1cf01b1011eca1c84b1d567a27398db3c993e23a03a6909356d7203aa101defb053dd9991c4ef718d8ce4a64d525d516a1b31a610b2b0cd60ab4d6e4896548
Size (R/waldo_0.3.0.tar.gz) = 33470 bytes

0 comments on commit bc8ca12

Please sign in to comment.