Skip to content

Commit

Permalink
(devel/p5-Module-ScanDeps)
Browse files Browse the repository at this point in the history
1.35  2023-11-05

- massive speed up, esp. for scripts using stuff from
  the Moose ecosystem, thanks to @shawnlaffan:

  - add package level caches for INC searches (_find_in_inc, _glob_in_inc)
  - faster add_deps on case insensitive systems AKA Windows

1.34  2023-09-24

- Fix issue #19 (AKA rschupp/PAR-Packer#78): invalid paths in zip file

  - Restore behaviour from version 1.31 when using "pp --execute ..." or
    "scandeps.pl --execute ...".

    When using "scan_deps(execute => 1, ...)", %INC as gleaned from
    running the script must be sanitized. Contrary to documentation
    "The  key  is the filename you specified (with module names
    converted to pathnames)" %INC *may* contain keys that are
    *absolute pathnames* (or start with "./relativ/path" when
    "relative/path" is in @path). Examples are autosplitted modules
    (for autosplit.ix and *.al files). pp will pack these absolute
    paths into the zip (Archive::Zip doesn't complain) which
    results in strange error messages when the packed executable
    tries to unpack them under CACHEDIR/inc on Windows.

    Add t/19-autosplit.t to test for this.
    Add IPC::Run3 to TEST_REQUIRES, used in t/19-autosplit.t

- Add GitHub CI

1.33  2023-08-04

- Recognize Moose/Moo/Mouse style inheritance ("extends")
  or composition ("with") statements.

- Add %Preload entries for known dependants of XS::Parse::Keyword.

  Note: XS::Parse::Keyword is loaded from XS code, grep.metacpan.org
  for calls of boot_xs_parse_keyword() in *.xs files.

1.32  2023-07-05

- Ensure $inc gets removed from the start of $File::Find::name

  On Windows, if $inc contains backslashes then it won't always get removed
  from the start of $File::Find::name because the latter may be canonicalized
  to only contain forward slashes.

- Provide dedicated test scripts for some tests instead of using
  the test scripts themselves: Test::More draws in all kinds of stuff,
  totally unpredictable

- Rewrite test helpers in t/Utils.pm to use Test::More's subtest feature

- Code cleanup; fix detection of 'do STRING' (cf PR #15)

- scandeps.pl:  sort items in "used by" column

- Handle spaces after quote operator, e.g. eval qq {Some::Module}

- Fixes #12: share dir not returned when require module is in an eval

- Recognize constructs like "eval qq{require Inline::C}".

- Recognize idioms like "if (eval { require Foo }) { ..."

- Add %preload rules for some Mojo resource files

  Fixes rschupp/PAR-Packer#44

- Bump perl dependency to guard against ancient perls without FindBin::again()

- Add tool to trace when (and from where) Perl searches for a module
  • Loading branch information
mef committed Dec 18, 2023
1 parent c2bec5c commit c38c4d2
Show file tree
Hide file tree
Showing 2 changed files with 6 additions and 7 deletions.
5 changes: 2 additions & 3 deletions devel/p5-Module-ScanDeps/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $NetBSD: Makefile,v 1.56 2023/07/06 09:39:34 wiz Exp $
# $NetBSD: Makefile,v 1.57 2023/12/18 13:35:44 mef Exp $

DISTNAME= Module-ScanDeps-1.31
DISTNAME= Module-ScanDeps-1.35
PKGNAME= p5-${DISTNAME}
PKGREVISION= 2
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN:=Module/}

Expand Down
8 changes: 4 additions & 4 deletions devel/p5-Module-ScanDeps/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.33 2021/10/26 10:17:00 nia Exp $
$NetBSD: distinfo,v 1.34 2023/12/18 13:35:44 mef Exp $

BLAKE2s (Module-ScanDeps-1.31.tar.gz) = 7ab728f7e99c62991e755b9fbef19033ab2360756ae8bcda51ab3b6d7ba3d78c
SHA512 (Module-ScanDeps-1.31.tar.gz) = c7164d768b6401a0d01516f5a09ddf2a0399355738ff17d04757aeb235b47f8d973083d0425ca53757588916c7fb2959d8c042361055a0e8eab7bf6d4c31d6fd
Size (Module-ScanDeps-1.31.tar.gz) = 56164 bytes
BLAKE2s (Module-ScanDeps-1.35.tar.gz) = b5399fc91947a11188b5c6901e15b79c02fe7a5fb79c6f4067f620d71330b794
SHA512 (Module-ScanDeps-1.35.tar.gz) = 314a8098883995d876bfae7760b569ade56eed1940e50f92a509fd0f2c0020d57da859bb8848c56a9e1dcb4acd62cd246c39424bc1c30d71c6defc9f491518b9
Size (Module-ScanDeps-1.35.tar.gz) = 59289 bytes

0 comments on commit c38c4d2

Please sign in to comment.