Skip to content

Commit

Permalink
wireshark: fix building with Glib 2.68
Browse files Browse the repository at this point in the history
  • Loading branch information
adam committed Mar 23, 2021
1 parent 36a2e22 commit cc9f8fd
Show file tree
Hide file tree
Showing 7 changed files with 132 additions and 1 deletion.
8 changes: 7 additions & 1 deletion net/wireshark/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,13 @@
$NetBSD: distinfo,v 1.139 2021/03/11 08:22:01 adam Exp $
$NetBSD: distinfo,v 1.140 2021/03/23 10:48:41 adam Exp $

SHA1 (wireshark-3.4.4.tar.xz) = fa5c553596dcc6a59735f96a9a0845e3c40abab2
RMD160 (wireshark-3.4.4.tar.xz) = 677c151b94af472ae3ae390e51781ec0cc371ddd
SHA512 (wireshark-3.4.4.tar.xz) = 388b5634894f08bb1a0052f989133c2a8457fbf6525d1bb557f3ffce73da8063fd9fe82b50b5ababc30fa36ce154bf9d2a3d91d76e03913d6516ca61b4b6b172
Size (wireshark-3.4.4.tar.xz) = 32290424 bytes
SHA1 (patch-CMakeLists.txt) = 8faf8f63d75d5733a69b52ce9fbf291bd90a5575
SHA1 (patch-caputils_capture__ifinfo.h) = 8eef1414274fae7a374776c2533343bf02ca114e
SHA1 (patch-epan_conversation.h) = b3cdd98602570cbcb33b35e9362ff8802753edd8
SHA1 (patch-epan_epan.h) = 869211117930b4a246f9bd1f199e3a201fdc39e3
SHA1 (patch-epan_epan__dissect.h) = 9fe4d59c38786c1981ada2dc356f0d01a0703bf0
SHA1 (patch-epan_prefs.h) = 4678aaaee9ea9e481b3d38f5bc491a86f7c0a75b
SHA1 (patch-ui_recent.h) = 3358ba7d6a292741d34274db9fb86c02541c861f
21 changes: 21 additions & 0 deletions net/wireshark/patches/patch-caputils_capture__ifinfo.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
$NetBSD: patch-caputils_capture__ifinfo.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- caputils/capture_ifinfo.h.orig 2021-03-23 09:25:20.000000000 +0000
+++ caputils/capture_ifinfo.h
@@ -11,12 +11,12 @@
#ifndef __CAPTURE_IFINFO_H__
#define __CAPTURE_IFINFO_H__

+#include <glib.h>
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

-#include <glib.h>
-
/*
* Explicitly set the interface_type enum values as these values are exposed
* in the preferences gui.interfaces_hidden_types string.
23 changes: 23 additions & 0 deletions net/wireshark/patches/patch-epan_conversation.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,23 @@
$NetBSD: patch-epan_conversation.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- epan/conversation.h.orig 2021-03-23 09:26:58.000000000 +0000
+++ epan/conversation.h
@@ -12,6 +12,7 @@
#define __CONVERSATION_H__

#include "ws_symbol_export.h"
+#include "packet.h" /* for conversation dissector type */

#ifdef __cplusplus
extern "C" {
@@ -46,8 +47,6 @@ extern "C" {
/* Flags to handle endpoints */
#define USE_LAST_ENDPOINT 0x08 /* Use last endpoint created, regardless of type */

-#include "packet.h" /* for conversation dissector type */
-
/* Types of port numbers Wireshark knows about. */
typedef enum {
ENDPOINT_NONE, /* no endpoint */
20 changes: 20 additions & 0 deletions net/wireshark/patches/patch-epan_epan.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
$NetBSD: patch-epan_epan.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- epan/epan.h.orig 2021-03-23 09:17:20.000000000 +0000
+++ epan/epan.h
@@ -10,11 +10,12 @@
#ifndef __EPAN_H__
#define __EPAN_H__

+#include <glib.h>
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

-#include <glib.h>
#include <epan/tvbuff.h>
#include <epan/prefs.h>
#include <epan/frame_data.h>
20 changes: 20 additions & 0 deletions net/wireshark/patches/patch-epan_epan__dissect.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
$NetBSD: patch-epan_epan__dissect.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- epan/epan_dissect.h.orig 2021-03-23 09:24:04.000000000 +0000
+++ epan/epan_dissect.h
@@ -10,11 +10,12 @@
#ifndef EPAN_DISSECT_H
#define EPAN_DISSECT_H

+#include "epan.h"
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

-#include "epan.h"
#include "tvbuff.h"
#include "proto.h"
#include "packet_info.h"
21 changes: 21 additions & 0 deletions net/wireshark/patches/patch-epan_prefs.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
$NetBSD: patch-epan_prefs.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- epan/prefs.h.orig 2021-03-23 08:55:05.000000000 +0000
+++ epan/prefs.h
@@ -11,12 +11,12 @@
#ifndef __PREFS_H__
#define __PREFS_H__

+#include <glib.h>
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

-#include <glib.h>
-
#include <epan/params.h>
#include <epan/range.h>

20 changes: 20 additions & 0 deletions net/wireshark/patches/patch-ui_recent.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,20 @@
$NetBSD: patch-ui_recent.h,v 1.1 2021/03/23 10:48:42 adam Exp $

Fix building with Glib 2.68.

--- ui/recent.h.orig 2021-03-23 09:22:16.000000000 +0000
+++ ui/recent.h
@@ -12,11 +12,12 @@
#ifndef __RECENT_H__
#define __RECENT_H__

+#include <glib.h>
+
#ifdef __cplusplus
extern "C" {
#endif /* __cplusplus */

-#include <glib.h>
#include <stdio.h>
#include "epan/timestamp.h"
#include "ui/ws_ui_util.h"

0 comments on commit cc9f8fd

Please sign in to comment.