Skip to content

Commit

Permalink
Update dte to 1.8.2.
Browse files Browse the repository at this point in the history
From Craig Barnes via Github PR.

Closes #47.

v1.8.2 (latest release)
-----------------------

Released on 2019-04-23.

**Changes:**

* Fixed makefile to work with GNU Make 3.81 (which is still used
  by OS X and Ubuntu 14.04).


v1.8.1
------

Released on 2019-04-22.

**Fixes:**

* Fixed parsing of escaped special characters in command arguments
  (which was causing Lua syntax highlighting to fail).
* Removed use of `rep` (repeat character) control sequence, due to
  problems caused by certain terminal emulators that claim to be
  "xterm" but don't support the full set of features in the xterm
  `terminfo(5)` entry (notably, the FreeBSD 12 console).

**Additions:**

* Show a confirmation prompt if Ctrl+q (quit) is pressed with unsaved
  changes, instead of a cryptic error message.


v1.8
----

Released on 2019-04-18.

**Additions:**

* Added support for 24-bit RGB terminal colors.
* Added support for `strikethrough` terminal attribute.
* Added support for `alias` names containing multi-byte Unicode characters.
* Added `refresh` command (to force a full screen redraw).
* Added `dte -K` command-line option (for keycode debugging).
* Added support for reading a buffer from `stdin` at startup.
* Added support for binding Ctrl/Alt/Shift + F1-F12 on xterm-like terminals.
* Added `-s` flag to `bol` command, to allow moving to beginning of indented
  text, before moving to beginning of line (a.k.a "smart home").
* Added `-c` flag to all cursor movement commands, to allow selecting
  characters while moving.
* Added `-l` flag to `up`, `down`, `pgup` and `pgdown` commands, to
  allow selecting whole lines while moving.
* Added default bindings for various Shift+key combinations, for doing
  GUI-style text selections.
* Added key bindings to command mode for deleting/erasing whole words
  (Alt+Delete and Alt+Backspace).

**Improvements:**

* Optimized built-in filetype detection.
* Fixed cursor interaction with Unicode combining characters.
* Improved handling of Unicode whitespace and unprintable characters.
* Updated character class lookup tables to Unicode 11.
* Expanded documentation for `hi` and `compile` commands.
* Optimized code to reduce editor startup and input latency.

**Breaking changes:**

* Changed the `bind` command to be much more strict when parsing key
  strings and show an error message when invalid. The caret (`^`)
  modifier can now only be used alone (not in combination with other
  modifiers) and the `C-`, `M-` and `S-` modifiers *must* be
  uppercase.
* Removed support for chained key bindings (e.g. `bind '^X c' ...`).
  Commands that aren't bound to simple key combinations can just be
  accessed via command mode.
* Removed support for recognizing some Ctrl/Alt/Shift key combinations
  produced by the `rxvt` terminal emulator. The key codes produced by
  `rxvt` violate the [ECMA-48] specification. Users of such terminals
  are encouraged to configure the key codes to mimic `xterm` instead.


v1.7
----

Released on 2018-05-08.

**Changes:**

* Added support for opening multiple files using glob patterns
  (e.g. `open -g *.[ch]`).
* Added support for binding more xterm extended key combinations
  (Ctrl/Meta/Shift + PageUp/PageDown/Home/End).
* Improved compiler error parsing for newer versions of GCC.
* Improved handling of underline/dim/italic terminal attributes
  (including support for the `ncv` terminfo capability).
* Many other small bug fixes and code improvements.


v1.6
----

Released on 2017-12-20.

**Changes:**

* Added new, default `dark` color scheme.
* Added Ctrl+G key binding to exit command mode.
* Added Ctrl+H key binding for `erase` command.
* Added syntax highlighting for TeX and roff (man page) files.
* Improved syntax highlighting of Python numeric literals.
* Improved syntax highlighting for CSS files.
* Added `ft -b` command for detecting file types from file basenames.
* Converted user documentation to Markdown format.
* Created new [website] for online documentation.
* Added support for terminfo extended (or "user-defined") capabilities.
* Added built-in support for `st` and `rxvt` terminals.
* Fixed some built-in regex patterns to avoid non-portable features.
* Fixed compiler warnings on NetBSD.
* Removed tilde expansion of `~username` from command mode, in order to
  avoid using `getpwnam(3)` and thereby allow static linking with GNU
  libc on Linux.
  • Loading branch information
bsiegert committed Apr 26, 2019
1 parent fd6702b commit d9f8767
Show file tree
Hide file tree
Showing 3 changed files with 11 additions and 8 deletions.
5 changes: 4 additions & 1 deletion editors/dte/DESCR
Original file line number Diff line number Diff line change
Expand Up @@ -4,10 +4,13 @@ Features:

- Multiple buffers/tabs
- Unlimited undo/redo
- Search and replace
- Regex search and replace
- Syntax highlighting
- Customizable color schemes
- Customizable key bindings
- Support for all xterm Ctrl/Alt/Shift key codes
- Command language with auto-completion
- Unicode 11 compatible text rendering
- Support for multiple encodings (using iconv)
- Jump to definition (using ctags)
- Jump to compiler error
4 changes: 2 additions & 2 deletions editors/dte/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.1 2017/11/24 06:46:01 kamil Exp $
# $NetBSD: Makefile,v 1.2 2019/04/26 14:57:57 bsiegert Exp $

DISTNAME= dte-1.5
DISTNAME= dte-1.8.2
CATEGORIES= editors
MASTER_SITES= ${MASTER_SITE_GITHUB:=craigbarnes/}
GITHUB_RELEASE= v${PKGVERSION_NOREV}
Expand Down
10 changes: 5 additions & 5 deletions editors/dte/distinfo
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: distinfo,v 1.1 2017/11/24 06:46:01 kamil Exp $
$NetBSD: distinfo,v 1.2 2019/04/26 14:57:57 bsiegert Exp $

SHA1 (dte-1.5.tar.gz) = d7986ebeed08a55b8fffbd597edbcfba43fac072
RMD160 (dte-1.5.tar.gz) = d4855277018dc95e2a73606a7f0c71b3864f14a4
SHA512 (dte-1.5.tar.gz) = 39c5c2ba22eff49ed167db122c72352eea9989f8799b04a86d3cdd1e38bf6617965e8e0fd94b6644e7cb626d343012f2c491517a036960bad7c628754dfbf605
Size (dte-1.5.tar.gz) = 223623 bytes
SHA1 (dte-1.8.2.tar.gz) = 6afe1855a44d7f4fd4d47e6c3a75ed25c2a6eca6
RMD160 (dte-1.8.2.tar.gz) = b30f1e09b756a30c1c0ea25a746a8e5b572d1e51
SHA512 (dte-1.8.2.tar.gz) = ed4cf6fb728521323e3489a87ec3c4185d2f780107468b40aa9d22e9319f0229e1726499d87204081b453c7e39301f6a39ab0b6d2a9d7a8fc528d006d3bd162e
Size (dte-1.8.2.tar.gz) = 267142 bytes

0 comments on commit d9f8767

Please sign in to comment.