Skip to content

Commit

Permalink
Update mawk to 20240123
Browse files Browse the repository at this point in the history
20240123
	+ improve manpage style/formatting.
	+ improve conversion of parameter of srand() when using srandom()
	  (Original-Mawk #66).
	+ minor improvement for configure script

20231210
	+ correct interator type in REcompile (Original-Mawk #73)
	+ improve configure script check for arc4random
	+ reduce compiler warnings in configure script checks

20231126
	+ fix a couple of problems reported by Coverity:
	  + modify cell_destroy() to set the string pointer to NULL if zfree()
	    might have freed it.
	  + replace a couple of strcpy's with loop.
	  + eliminate a fixed-size array in re_cmpl.c
	+ change casts in strftime() and srand() to avoid truncation on 64-bit
	  machines (report by John Naman).

20231102
	+ environment-fixes for building with Solaris 10.

20231101
	+ repair parsing for comma-separated -W options used in "#" lines
	  (report by Leif Baron).
	+ updated makedeps.sh and examples/deps.awk, to update Makefile.in
	+ remove obsolete/incorrect zero-termination assignment from fillbuff()
	  (Original-Mawk #71).
	+ updated configure macros
	+ update config.guess and config.sub

20230816
	+ start work on _CALLX
	+ da.c:  replace most of the string-literals in fprintf's with result
	  from da_op_name()
	+ da.c, mawk.h:  simplify ifdef for da_op_name(), to reuse in
	  refactoring of _CALL
	+ da.c:  dumping the function name in front of the offset is
	  distracting, use just "@"
	+ da.c: make the trace show offsets like the -Wdump option
	+ da.c:  add traces to show which function is being dumped (and
	  possibly patched).  this improves on the fix for dump_funcs() as well,
	  freeing the linked-list
	+ code.c: fix a use-after-free when no-leaks and traces are combined.
	+ code.c: add trace to be_setup()
	+ parse.y: make trace message consistent with fcall.c
	+ execute.c: eliminate a couple of comparisons
	+ change SYMTAB_TYPES to mixed enum/masks, to reduce comparisons for
	  array types.
	+ some cleanup, using NUM_ARGS and SYM_TYPE typedefs.

20230808
	+ modify input buffer-resizing to improve performance with very long
	  longs (report/testcase by Leif LeBaron).

20230804
	> fixes for nulls (patches by Miguel Pineiro Jr).
	  + support nulls in toupper() and tolower().
	  + modify str_str() to ensure lengths for key/target are large enough
	    for the memcmp() call.
	+ treat special case of failure to open input file due to too many open
	  files as a fatal error (report/testcase by Christoph Brunhuber).
	+ fix a shift/reduce conflict for length vs length()
	+ quote string-parameter in a few error-messages
	+ add MinGW-code for system() calls (Original-Mawk #51).

20230730
	+ rexp.c: do not unroll repetition into loops if the repetition applies
	  to more than one character.
	+ rexp3.c: increment machine on completing M_2JC step to fix a case
	  with infinite loop.
	+ print.c: improve parameter-passing, eliminating a duplicate check.

20230726
	+ modify makefile to install mawk-array and mawk-code manpages.

20230725
	+ use da_string more consistently in dumps.
	+ improve scanner to some type-checks of arrays versus scalars by
	  deferring this into the runtime execution (report by Rajeev V Pillai).

20230716
	+ modify scanner to accommodate scripts which use the same name for
	  some function-parameters as for a function (report by Kaz Kylheku).
	+ amend/limit special case optimization for redundant wildwards
	  (Original-Mawk #36).
	+ regenerate parse.c using byacc 20230521

20230525
	+ fix a regression for big-endian machines caused by mismatch between
	  printf/sprintf format and long integer types (Original-Mawk #69, cf:
	  20200731).

20230404
	+ add a null-pointer check in bi_mktime() (Original-Mawk #57).
	+ cast parameter of srand() to double if it is not already (patch by
	  "q3cpma", Original-Mawk #66).
	+ manpage fixes (report/suggested by David Apps).
	+ fix parsing of "--" token on command-line, from 20200828 changes
	  (report by Pavel Vinogradov).
	+ add a null-pointer check in the case for "-W" when parsing command
	  options (Original-Mawk #68).
	+ improve CF_XOPEN_SOURCE configure macro to avoid clearing the host's
	  definition for _XOPEN_SOURCE if _POSIX_C_SOURCE is defined (report
	  by A. Wilcox).
	+ modify makefile "clean" rule to remove ".i" files.
	+ modify configure script to allow for using clock_gettime vs
	  gettimeofday.

20230322
	+ remove an unwanted string/number conversion in print.c, from changes
	  in 20200717 (report by Jan Psota).
	+ reduce compiler-warnings in configure script checks.

20230215
	+ update URLs, changing ftp to https
	+ modify configure.in, moving checks for standard headers before the
	  options, to improve check for arc4random (Redhat #2167291).

20230203
	+ split up do_printf to fix build with fortified mingw stdio.h
	+ reduce compiler-warnings in configure script checks.

20221229
	+ fix shellcheck warnings in test-scripts.
	+ updated configure macros
	+ update config.guess, config.sub, and install-sh

20210824
	+ updated configure macros
	+ update config.guess and config.sub

20210528
	+ add FreeBSD build-scripts, for test-builds
	+ updated configure macros
	+ update config.guess and config.sub

20201023
	+ start work on experimental approach to interval-expressions which
	  does not involve loop-unrolling.
	+ improve type-checking for builtin-regex's by using PTR only for the
	  external-regex's.
	+ improve dump format, showing intervals in curly-brace format.

20201016
	+ improve dump format, showing the jump-targets rather than offsets.

20201009
	+ show limits for brace-expressions in dump.
	+ change RE_panic to stdarg, and log its message in trace file

20200925
	+ improve compatibility vs gawk/bwk in gsub handling of backslash by
	  only escaping backslash with itself if those backslashes happen to
	  precede a "&", e.g., "\\&" vs "\\" (Original-Mawk #14).
	+ fix a regression in recent command-line option parsing.
	+ modify configure/makefile to use .PHONY if available.
	+ review/improve example-scripts

20200918
	+ build-fix for HP-UX 11.23, which lacks #define's for maximum of
	  int64_t and uint64_t
	+ build-fix for OpenBSD, which mis-types int64_t, just like macOS.
	+ build-fix for macOS, which mis-types int64_t

20200911
	+ improve range of printf/sprintf for decimal formats by using the
	  unsigned limit if the value is positive.
	+ improve checks for command-line numeric options.
	+ allow long-options to be abbreviated.

20200828
	+ modify configure script to move gcc -Werror flags to EXTRA_CFLAGS
	  to avoid breaking configure-checks.
	+ use sprintf-buffer for intermediate output of strftime, to handle
	  extra-long format strings.
	+ modify MAWK_LONG_OPTIONS "ignore" to limit that to the "-xxx" options
	  in this set of changes, plus the existing --lint/--lint-old options.
	+ allow -Wxxx options to use long-option format as -xxx, for better
	  script-compatibility with gawk.
	+ use standard output for -Whelp, but show usage message in standard
	  error when no command arguments are given.
	+ print version for -Wversion consistently in standard output.
	+ improve use of const for making tables readonly.
	+ change -W compat to -W traditional for better script-compatibility
	  with gawk.

20200821
	+ completed first draft of mawk-code.7

20200807
	+ begin man/mawk-code.7
	+ drop noweb dependency, move docs to man/mawk-arrays.7

20200731
	+ amend fix for Debian #303825 to more closely match gawk and BWK.
	  Those use larger data types, e.g., long vs int, for limits, and also
	  provide for using int64_t and uint64_t.  Internally, mawk now uses
	  long long's where those are supported.
	+ add --help and --version options

20200724
	+ modify logic for "{0}" in rexp.c so that a left-parenthesis is not
	  trimmed when cancelling the previous token.
	+ modify RE_cat to add a dummy M_ACCEPT as a workaround for logic in
	  the new RE_init_it_cnt and RE_set_limit functions.
	+ modify regexp_system.c to work with interval-expressions.
	+ recognize gawk's --traditional and --posix as aliases for mawk's
	  -W options, as well as -r and --re-interval to improve scripting
	  compatibility.
	+ add -W compat and -W posix, using the former to replace
	  -W repetitions and the latter to replace -W posix_space
	+ enable interval-expressions by default.

20200717
	+ add configure option "--disable-interval-expr"
	> integrated/adapted changes by James Parkinson (jlp765):
	+ add regexp intervals,
	+ add tests for intervals to test/mawktest and associated
	  test/repetitions files,
	+ add -W repetitions to enable r{m,n}
	+ add man page updates to man/mawk.1

20200708
	+ update manpage comment about "nextfile" (AustinGroup #607).
	+ amend manpage comment about "fflush" (AustinGroup #634).
	+ amend manpage comment about "delete array" (AustinGroup #544).
	+ updated configure macros
	+ update config.guess and config.sub
  • Loading branch information
cheusov committed May 10, 2024
1 parent a7f76fc commit ddf2c11
Show file tree
Hide file tree
Showing 3 changed files with 11 additions and 16 deletions.
15 changes: 4 additions & 11 deletions lang/mawk/Makefile
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@
# $NetBSD: Makefile,v 1.34 2021/03/02 02:53:40 gutteridge Exp $
# $NetBSD: Makefile,v 1.35 2024/05/10 11:53:13 cheusov Exp $

DISTNAME= mawk-1.3.4-20200120
PKGNAME= ${DISTNAME:S/-20/.20/}
DISTNAME= mawk-1.3.4-20240123
PKGNAME= ${DISTNAME:S/-24/.24/}
CATEGORIES= lang
MASTER_SITES= ftp://ftp.invisible-island.net/mawk/
MASTER_SITES= https://invisible-island.net/archives/mawk/
EXTRACT_SUFX= .tgz

MAINTAINER= cheusov@NetBSD.org
Expand All @@ -17,11 +17,4 @@ INSTALLATION_DIRS= ${PKGMANDIR}/man1

TEST_TARGET= mawk_test fpe_test

.include "../../mk/bsd.prefs.mk"

# mawk configure fails with -ffast-math
CFLAGS:= ${CFLAGS:S/-ffast-math//}

MAKE_ENV.SunOS+= CPPFLAGS=

.include "../../mk/bsd.pkg.mk"
4 changes: 3 additions & 1 deletion lang/mawk/PLIST
Original file line number Diff line number Diff line change
@@ -1,3 +1,5 @@
@comment $NetBSD: PLIST,v 1.3 2014/03/13 16:35:23 adam Exp $
@comment $NetBSD: PLIST,v 1.4 2024/05/10 11:53:13 cheusov Exp $
bin/mawk
man/man1/mawk.1
man/man7/mawk-arrays.7
man/man7/mawk-code.7
8 changes: 4 additions & 4 deletions lang/mawk/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.22 2021/10/26 10:51:42 nia Exp $
$NetBSD: distinfo,v 1.23 2024/05/10 11:53:13 cheusov Exp $

BLAKE2s (mawk-1.3.4-20200120.tgz) = dbfbda15ca6ff5c68ce03053567c67be8453cbd54bb0157766ed982efbf29a2f
SHA512 (mawk-1.3.4-20200120.tgz) = 14d9a6642ce931bf6457d248fc2d6da4f0ea7541976ca282ea708b26df048f86fdf92c27f72d497501ccd43a244d1d1a606f1a2f266a7558306fea35dcc3041b
Size (mawk-1.3.4-20200120.tgz) = 468855 bytes
BLAKE2s (mawk-1.3.4-20240123.tgz) = 6acba7698dd77413d83acff20a3b17837d4ca861d2924d9a2e3e53062e69e46f
SHA512 (mawk-1.3.4-20240123.tgz) = f6d5da44280afeac4a9bb6d3788ed71ee816daaa5816f49b9d40add5292f3ae06e5af007a6c993d14405238cbb70ba4997fdd2fcd5901c9a1a4b61357045c4a6
Size (mawk-1.3.4-20240123.tgz) = 413943 bytes

0 comments on commit ddf2c11

Please sign in to comment.