Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

gphotofs, spacefm and glmark2 PKGBUILDs create #1989

Open
wants to merge 10 commits into
base: master
Choose a base branch
from
39 changes: 39 additions & 0 deletions aur/2fa/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Maintainer: Alex Natalsson <HarmoniesWorlds@gmail.com>
# Contributor: Dmitri Goutnik <dg@syrec.org>
# Contributor: Doron Behar <doron.behar@gmail.com>

pkgname=2fa
pkgver=1.2.0
pkgrel=1
pkgdesc="Two factor authentication agent"
arch=('aarch64')
url='https://github.com/rsc/2fa'
license=('BSD')
makedepends=('go')
conflicts=('2fa-git')
replaces=('2fa-git')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=("SKIP")

prepare() {
mkdir -p src/rsc.io
mv ${pkgname}-${pkgver} src/rsc.io/2fa
}

build() {
cd src/rsc.io/2fa
env GOPATH="${srcdir}" go mod vendor && go build
}

# check() {
# cd src/rsc.io/2fa
# env GOPATH="${srcdir}" go test
# }

package() {
cd src/rsc.io/2fa
install -Dm755 2fa "${pkgdir}/usr/bin/${pkgname}"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}

# vim:set ts=2 sw=2 et:
21 changes: 21 additions & 0 deletions aur/arm-none-eabi-toolchain-bin/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
# Mantainer: Alex Natalsson <HarmoniesWorlds@gmail.com>

buildarch=8
_target='arm-none-eabi'
pkgname=${_target}'-toolchain-bin'
pkgver=12.3.rel
pkgrel=1
pkgdesc="The GNU Compiler Collection Toolchain for (${_target})"
arch=('aarch64')
license=('GPL')
url="https://developer.arm.com/"
depends=('ncurses5-compat-libs')
source=("https://developer.arm.com/-/media/Files/downloads/gnu/${pkgver}${pkgrel}/binrel/arm-gnu-toolchain-${pkgver}${pkgrel}-${arch}-${_target}.tar.xz")
sha256sums=('14c0487d5753f6071d24e568881f7c7e67f80dd83165dec5164b3731394af431')

package() {
mkdir -p ${pkgdir}/usr/local/
cp -a ${srcdir}/arm-gnu-toolchain-${pkgver}${pkgrel}-${arch}-${_target}/* ${pkgdir}/usr/local/
mkdir ${pkgdir}/usr/lib/
ln -s /usr/lib/libpython3.11.so.1.0 ${pkgdir}/usr/lib/libpython3.8.so.1.0
}
37 changes: 37 additions & 0 deletions aur/gphotofs/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Alex Natallson <HarmoniesWorlds@gmail.com>
#
pkgname=gphotofs
pkgver=0.5
pkgrel=3
pkgdesc="FUSE filesystem module to mount your camera as a filesystem on Linux."
arch=('aarch64')
url="http://www.gphoto.org/proj/gphotofs/"
license=('GPL2')
depends=('fuse' 'glib2' 'libgphoto2')
buildarch=8
makedepends=('pkgconfig')
source=("http://downloads.sourceforge.net/sourceforge/gphoto/gphotofs-${pkgver}.tar.bz2"
"https://git.savannah.gnu.org/cgit/config.git/plain/config.guess"
"https://git.savannah.gnu.org/cgit/config.git/plain/config.sub"
)
sha256sums=('676ec4de69a81c193ffc31bdc7b587ac2a2cc3780b14f0e7c9c4c0a517b343cc'
'd4b8b6815be8fe5eee29a72e6272ee2a67cfdd0e43f438c8ee2b33570335dc3d'
'71b8d73e46e0c31b1dc91ba5306f5ef0af009273b3bb283f31d8dad69666fa9e'
)

prepare() {
cd "${srcdir}/gphotofs-${pkgver}"
cp ../config.guess auto-aux/
cp ../config.sub auto-aux/
}

build() {
cd "${srcdir}/gphotofs-${pkgver}"
./configure --prefix=/usr
make
}

package() {
cd "${srcdir}/gphotofs-${pkgver}"
make DESTDIR="${pkgdir}" install
}
36 changes: 36 additions & 0 deletions aur/librnd4/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Maintainer: Alex Natalsson <HarmoniesWorlds@gmail.com>
#
pkgname=librnd4
pkgver=4.0.2
pkgrel=2
pkgdesc="free/open source, flexible, modular two-dimensional CAD engine"
url="http://www.repo.hu/projects/librnd/"
arch=('aarch64')
buildarch='0000 1000'
license=('GPL2')
depends=(glibc bash)
optdepends=('gtk2: GTK2 GUI'
'gtkglext: GTK2 GUI, OpenGL render'
'libepoxy: GTK4 GUI'
'openmotif: the lesstif GUI'
'libstroke: mouse gestures'
'gd: to export/import to/from png, jpg or gif'
'fungw: turing complete scripting')
source=("http://www.repo.hu/projects/librnd/releases/librnd-$pkgver.tar.gz")
sha256sums=('1cba7fa6f3bcea318ee813363d4033af6ea1e6c9db104996a682989ef085369a')

build() {
cd "$srcdir/librnd-$pkgver/"
./configure --prefix=/usr
make
}

check() {
cd "$srcdir/librnd-$pkgver/"
make test
}

package() {
cd "$srcdir/librnd-$pkgver/"
make DESTDIR="$pkgdir/" install
}
65 changes: 65 additions & 0 deletions aur/ncurses5-compat-libs/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,65 @@
# Maintainer: Alex Natalsson <HarmoniesWorlds@gmail.com>
# Maintainer: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
# Maintainer: Mateusz Gozdek <mgozdekof@gmail.com>
# Contributor: Allan McRae <allan@archlinux.org>
# Contributor: judd <jvinet@zeroflux.org>

buildarch=8
pkgname=ncurses5-compat-libs
_pkgname=ncurses
pkgver=6.4
pkgrel=2
pkgdesc='System V Release 4.0 curses emulation library, ABI 5'
arch=(aarch64)
url='http://invisible-island.net/ncurses/ncurses.html'
license=(MIT)
depends=(glibc gcc-libs sh)
provides=(libtinfo5)
conflicts=(libtinfo5)
source=(https://ftp.gnu.org/pub/gnu/ncurses/ncurses-$pkgver.tar.gz)
sha256sums=('6931283d9ac87c5073f30b6290c4c75f21632bb4fc3603ac8100812bed248159'
)
#validpgpkeys=('19882D92DDA4C400C22C0D56CC2AF4472167BE03') # Thomas Dickey

prepare() {
cp -r ${_pkgname}-${pkgver}{,-no-widec}
}

build() {
local configure_options=(
--prefix=/usr
--mandir=/usr/share/man
--with-shared
--with-normal
--without-debug
--without-ada
--disable-pc-files
--with-cxx-binding
--with-cxx-shared
--with-versioned-syms
--with-abi-version=5
)

cd "${srcdir}/${_pkgname}-${pkgver}"

./configure "${configure_options[@]}" --enable-widec
make

cd "${srcdir}/${_pkgname}-${pkgver}-no-widec"

./configure "${configure_options[@]}"
make
}

package() {
cd "${srcdir}/${_pkgname}-${pkgver}"
make DESTDIR="$pkgdir" install.libs
cd "${srcdir}/${_pkgname}-${pkgver}-no-widec"
make DESTDIR="$pkgdir" install.libs
install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
rm -rf "$pkgdir/usr/include/" "$pkgdir/usr/lib/pkgconfig" \
"$pkgdir"/usr/lib/*.so "$pkgdir"/usr/lib/*.a

ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtinfo.so.5"
ln -s /usr/lib/libncurses.so.5 "$pkgdir/usr/lib/libtic.so.5"
}
28 changes: 28 additions & 0 deletions aur/pcb-rnd/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Maintainer: Alex Natalsson <HarmoniesWorlds@gmail.com>
#
pkgname=pcb-rnd
pkgver=3.1.2
pkgrel=1
pkgdesc="free/open source, flexible, modular Printed Circuit Board editor"
url="http://www.repo.hu/projects/pcb-rnd/"
arch=('aarch64')
buildarch='0000 1000'
license=('GPL2')
depends=('librnd4>=4.0.0'
'libxml2')
optdepends=('freetype2: import_ttf plugin'
'fungw'
'imagemagick: for running the pixmap export tests')
source=("http://www.repo.hu/projects/$pkgname/releases/$pkgname-$pkgver.tar.gz")
sha256sums=('eb378dd59bbe8006c8f5b5d0905863965acf5f2256041a14a9b493cb150977c2')

build() {
cd "$srcdir/$pkgname-$pkgver/"
./configure --prefix=/usr
make
}

package() {
cd "$srcdir/$pkgname-$pkgver/"
make DESTDIR="$pkgdir/" install
}
32 changes: 32 additions & 0 deletions aur/sch-rnd/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,32 @@
# Maintainer: Alex Natalsson <HarmoniesWorlds@gmail.com>
#
pkgname=sch-rnd
pkgver=1.0.2
pkgrel=1
pkgdesc="simple, modular, scriptable schematics editor"
url="http://www.repo.hu/projects/pcb-rnd/"
arch=('aarch64')
buildarch='0000 1000'
license=('GPL2')
depends=('librnd4>=4.0.0'
'libxml2')
optdepends=('freetype2: import_ttf plugin'
'fungw')
source=("http://www.repo.hu/projects/$pkgname/releases/$pkgname-$pkgver.tar.gz")
sha256sums=('48372953a0418447ffb578b64ce40874ae78f9976a3d99b69ceab900bc7fd169')

build() {
cd "$srcdir/$pkgname-$pkgver/"
./configure --prefix=/usr
make
}

check() {
cd "$srcdir/$pkgname-$pkgver/"
make test
}

package() {
cd "$srcdir/$pkgname-$pkgver/"
make DESTDIR="$pkgdir/" install
}
63 changes: 63 additions & 0 deletions aur/spacefm/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,63 @@
# Maintainer: Alex Natallson <HarmoniesWorlds@gmail.com>
# Contributor: Janne Heß <jannehess@gmail.com>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
# Contributor: IgnorantGuru http://igurublog.wordpress.com/contact-ignorantguru/
# Contributor: ridikulus_rat <the.ridikulus.rat@gmail.com>

pkgname=spacefm
pkgver=1.0.6
pkgrel=3
pkgdesc='Multi-panel tabbed file manager'
arch=(aarch64)
buildarch=8
url="https://ignorantguru.github.io/spacefm/"
license=(GPL3)
depends=(gtk3 startup-notification ffmpegthumbnailer)
makedepends=(intltool)
optdepends=('dbus: dbus integration'
'util-linux: disk eject support'
'lsof: device processes'
'wget: plugin download'
'gksu: perform as root functionality'
'udevil: mount as non-root user and mount networks'
'udisks2: mount as non-root user'
'pmount: mount as non-root user'
'curlftpfs: mount FTP shares'
'jmtpfs: mount MTP devices'
'gphotofs: mount cameras'
'ifuse: mount your iPhone/iPod Touch'
'fuseiso: mount ISO files')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/${pkgver}.tar.gz"
"https://github.com/FabioLolix/AUR-artifacts/raw/master/spacefm-Fix-GCC-10-build.patch"
"https://raw.githubusercontent.com/FabioLolix/AUR-artifacts/master/spacefm-glibc-2.28-compatibility.patch"
"https://git.savannah.gnu.org/cgit/config.git/plain/config.guess"
"https://git.savannah.gnu.org/cgit/config.git/plain/config.sub"
)
sha256sums=('fedea9fcad776e0af4b8d90c5a1c86684a9c96ef1cdd4e959530ce93bdebe7c9'
'16622d0d56c40e87e846a81709d9c2c8303f189e53a783bf20ccdb57b8f9465f'
'12411055df994211d2968cb52746b6caefce6926aed1ed33b542bd70b571ce7e'
'd4b8b6815be8fe5eee29a72e6272ee2a67cfdd0e43f438c8ee2b33570335dc3d'
'71b8d73e46e0c31b1dc91ba5306f5ef0af009273b3bb283f31d8dad69666fa9e'
)

prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
patch -Np1 -i ../spacefm-glibc-2.28-compatibility.patch
patch -Np1 -i ../spacefm-Fix-GCC-10-build.patch
cp ../config.guess .
cp ../config.sub .
}

build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./configure \
--prefix=/usr \
--with-gtk3
make
}

package() {
cd "${srcdir}/${pkgname}-${pkgver}"
make DESTDIR="${pkgdir}" install
rm -f "$pkgdir"/usr/bin/spacefm-installer
}
33 changes: 33 additions & 0 deletions community/glmark2/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Maintainer: Alex Natallson <Harmoniesworlds@gmail.com>
# Contributor: farseerfc <farseerfc@gmail.com>
pkgname=glmark2
pkgver=2023.01
pkgrel=1
pkgdesc="An OpenGL 2.0 and ES 2.0 benchmark"
arch=('x86_64' 'aarch64')
buildarch=8
url="https://github.com/glmark2/glmark2"
license=('GPL3' 'custom')
depends=('egl-wayland' 'libjpeg-turbo' 'libpng' 'libx11' 'systemd-libs')
makedepends=('meson' 'systemd' 'mesa' 'wayland-protocols')
source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
sha256sums=('8fece3fc323b643644a525be163dc4931a4189971eda1de8ad4c1712c5db3d67')

build() {
arch-meson "$pkgname-$pkgver" build \
-Dflavors=drm-gl,drm-glesv2,wayland-gl,wayland-glesv2,x11-gl,x11-glesv2
meson compile -C build
}

# No tests defined
#check() {
# meson test -C build --print-errorlogs
#}

package() {
meson install -C build --destdir "$pkgdir"

cd "$pkgname-$pkgver"
install -Dm644 COPYING.SGI -t "$pkgdir/usr/share/licenses/$pkgname"
}