Skip to content

Commit

Permalink
Bump version to 0.7.0
Browse files Browse the repository at this point in the history
  • Loading branch information
gentoo90 committed Feb 26, 2020
1 parent 067f0ef commit 1e8314a
Show file tree
Hide file tree
Showing 4 changed files with 11 additions and 6 deletions.
2 changes: 1 addition & 1 deletion Cargo.toml
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = "winreg"
version = "0.6.2"
version = "0.7.0"
authors = ["Igor Shaula <gentoo90@gmail.com>"]
license = "MIT"
description = "Rust bindings to MS Windows Registry API"
Expand Down
11 changes: 8 additions & 3 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -33,7 +33,7 @@ Current features:
```toml
# Cargo.toml
[dependencies]
winreg = "0.6"
winreg = "0.7"
```

```rust
Expand Down Expand Up @@ -132,7 +132,7 @@ fn main() -> io::Result<()> {
```toml
# Cargo.toml
[dependencies]
winreg = { version = "0.6", features = ["transactions"] }
winreg = { version = "0.7", features = ["transactions"] }
```

```rust
Expand Down Expand Up @@ -174,7 +174,7 @@ fn main() -> io::Result<()> {
```toml
# Cargo.toml
[dependencies]
winreg = { version = "0.6", features = ["serialization-serde"] }
winreg = { version = "0.7", features = ["serialization-serde"] }
serde = "1"
serde_derive = "1"
```
Expand Down Expand Up @@ -259,6 +259,11 @@ fn main() -> Result<(), Box<Error>> {

## Changelog

### 0.7.0

* Breaking change: remove deprecated `Error::description` ([#28](https://github.com/gentoo90/winreg-rs/pull/28))
* Optimize `Iterator::nth()` for the `Enum*` iterators ([#29](https://github.com/gentoo90/winreg-rs/pull/29))

### 0.6.2

* Add `RegKey::delete_subkey_with_flags()` ([#27](https://github.com/gentoo90/winreg-rs/pull/27))
Expand Down
2 changes: 1 addition & 1 deletion appveyor.yml
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
version: 0.6.{build}
version: 0.7.{build}
pull_requests:
do_not_increment_build_number: true

Expand Down
2 changes: 1 addition & 1 deletion src/lib.rs
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
//!```toml,ignore
//!# Cargo.toml
//![dependencies]
//!winreg = "0.6"
//!winreg = "0.7"
//!```
//!
//!```no_run
Expand Down

0 comments on commit 1e8314a

Please sign in to comment.