Skip to content

ldpacl/simple_company_network

Folders and files

NameName
Last commit message
Last commit date

Latest commit

 

History

8 Commits
 
 
 
 

Repository files navigation

Simple Company Network using Cisco Packet Tracer

Problem Statement

XYZ company is a fast-growing comapany in Bangalore with more than 2 million customers globally. The company deals with selling and buying food items, which are basically operated from the headquarters. The company is intending to open a branch near the local village. Thus, the company requires young IT graduates to design the network for the branch. The network is intended to operate separately from the HQ network.

Being a small network, the company has the following requirements during implementation

  1. One router and one switch to be used(all CISCO products).
  2. 3 departments(Admin/IT, Finance/HR and Customer service/Reception).
  3. Each department is required to be in different VLANS.
  4. Each department is required to have wireless network for the users.
  5. Host devices in the network are required to obtain IPv4 address automatically.
  6. Devices in all the departments are required to communicate with each other.

Assume the ISP gave out a base network of 192.168.1.0, design and implement a network considering the above requirements

Solution:

    Network address: 192.168.1.0        Subnet mask: 255.255.255.192
    Number of Subnets = 3
    2^n=3    Therefore n=2(number of borrowed bits)
  

New subnet mask: 255.255.255.192

Block size = 64

1st Subnet

Network ID 192.168.1.0
Broadcast ID 192.168.1.63
Host range 192.168.1.1 - 192.168.1.62

2nd Subnet

Network ID 192.168.1.64
Broadcast ID 192.168.1.127
Host range 192.168.1.65 - 192.168.1.126

3rd Subnet

Network ID 192.168.1.128
Broadcast ID 192.168.1.191
Host range 192.168.1.129 - 192.168.1.190

Configuring VLAN in switch

  en
  conf t
  int range fa 0/2-4
  switchport access vlan 10

Repeat the above steps for all other VLANs

  do wr
  do show start

Configuring Access Points

  click on AP
  go to port 1
  type SSID of choice
  click WPA2-PSK
  type pass phrase of choice

Repeat the above steps for all other APs

Trunking of VLAN

  int fa 0/1
  switchport mode trunk

Router Configuration

  en
  int gig 0/0
  no shutdown
  do wr

Configuring sub-interface for vlans

  int gig 0/0.10
  encapsulation dot1Q 10
  ip address 192.168.1.1 255.255.255.192
  exit

Repeat the above steps for all other subinterfaces

Configuring DHCP service

  conf t
  service dhcp
  ip dhcp pool Admin-Pool
  network 192.168.1.0 255.255.255.192
  default-router 192.168.1.1
  dns server 192.168.1.1
  domain-name Admin.com
  exit

Repeat the above steps for all other subinterfaces

Checking DHCP

  go to host
  click in ip coonfiguration
  enable dhcp
  check if the host is getting it's ip address automatically

Check for all the hosts

Connecting wirelessly to Acess Points

Laptop

  poweroff
  remove module
  insert wifi module
  power on 
  go to desktop
  go to wireless
  select SSID
  type password

Smartphone

  go to config
  go to wireless0
  type SSID
  type password

Checking connectivity between hosts

  ping host-ipaddress