Skip to content

Commit

Permalink
freeswitch: add patch moving package to PCRE2
Browse files Browse the repository at this point in the history
Add paending patch moving package to PCRE2 as PCRE is EOL and won't
receive any updates anymore.

These patch were run uder the freeswitch CI and were validated with
their unit tests.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
  • Loading branch information
Ansuel committed Nov 3, 2023
1 parent 5f998af commit 04b1dea
Show file tree
Hide file tree
Showing 3 changed files with 1,836 additions and 2 deletions.
4 changes: 2 additions & 2 deletions net/freeswitch/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=freeswitch
PKG_VERSION:=1.10.10
PKG_RELEASE:=2
PKG_RELEASE:=3
PKG_MAINTAINER:=Sebastian Kemper <sebastian_ml@gmx.net>

PKG_SOURCE:=freeswitch-$(PKG_VERSION).-release.tar.xz
Expand Down Expand Up @@ -320,7 +320,7 @@ $(call Package/freeswitch/Default)
+libcurl \
+libedit \
+libopenssl \
+libpcre \
+libpcre2 \
+libpthread \
+librt \
+libspandsp3 \
Expand Down
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
From 2a4c882464b792ac827c98b5d09e5a89b471a75a Mon Sep 17 00:00:00 2001
From: Christian Marangi <ansuelsmth@gmail.com>
Date: Fri, 3 Nov 2023 17:27:06 +0100
Subject: [PATCH 1/3] [mod_verto] Fix memory leak by correctly freeing regex

For mod_verto regex was never freed and was actually leaking memory.
Correctly free the compiled regex to fix the memory leak.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
---
src/mod/endpoints/mod_verto/mod_verto.c | 2 ++
1 file changed, 2 insertions(+)

--- a/src/mod/endpoints/mod_verto/mod_verto.c
+++ b/src/mod/endpoints/mod_verto/mod_verto.c
@@ -1893,10 +1893,12 @@ authed:
switch_log_printf(SWITCH_CHANNEL_LOG, SWITCH_LOG_DEBUG,
"%d request [%s] matched expr [%s]\n", proceed, request->uri, expression);
request->uri = rule->value;
+ switch_regex_safe_free(re);
break;
}

rule = rule->next;
+ switch_regex_safe_free(re);
}
}

Loading

0 comments on commit 04b1dea

Please sign in to comment.